{"answers":{"affected":"4 open source packages ship an affected version, including postcss-selector-parser.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-9358 exists.","fix":"Upgrade postcss-selector-parser to a fixed version for your release line: 6.1.3 or 7.1.3.","what":"CVE-2026-9358 is a medium-severity denial of service vulnerability in postcss-selector-parser, published on 24 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-9358 and fix it if it is affected.\n\nWhat it is: CVE-2026-9358 is a medium-severity denial of service vulnerability in postcss-selector-parser, published on 24 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-9358 exists.\n\nAffected packages and fixed versions:\n- postcss-selector-parser (npm): affected from 6.1.0; fixed in 6.1.3\n- postcss-selector-parser (npm): affected from 6.1.0; fixed in 6.1.3\n- postcss-selector-parser (npm): affected from 7.1.0; fixed in 7.1.3\n- postcss-selector-parser (npm): affected from 7.1.0; fixed in 7.1.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-9358/ (Markdown: https://insights.sbomify.com/CVE-2026-9358/index.md)","id":"CVE-2026-9358","markdown":"https://insights.sbomify.com/CVE-2026-9358/index.md","name":"CVE-2026-9358","record":{"aliases":["CLEANSTART-2026-IM94459","CLEANSTART-2026-RL61109","CLEANSTART-2026-YG53866","DEBIAN-CVE-2026-9358","GHSA-w9m9-85wc-3x92","MINI-2mpc-j838-xg3w","MINI-4vf3-hmrw-72qg","MINI-66w7-948f-8vrj","MINI-7r95-vmm8-xf8g","MINI-9h9m-w797-m8p8","MINI-gqx7-mq5m-64p2","MINI-gw67-5fcm-r9cx","MINI-jqm3-2wgc-gf9x","MINI-qrg9-hvgh-8c76","MINI-wf4f-6w9v-qp77","UBUNTU-CVE-2026-9358"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"CSS parsing library","requires_auth":"none","summary":"Remote attackers can cause denial of service via uncontrolled recursion in postcss-selector-parser's AST serialization, requiring an upgrade to fix.","user_interaction":"required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:P","version":"4.0"},"cwes":[{"id":"CWE-674","name":"Uncontrolled Recursion"},{"id":"CWE-404","name":"Improper Resource Shutdown or Release"}],"description":"A vulnerability was determined in postcss-selector-parser up to 6.1.2/7.1.2. Affected is the function toString of the file src/selectors/container.js of the component AST Serialization. Executing a manipulation can lead to uncontrolled recursion. It is possible to launch the attack remotely. The exploit has been publicly disclosed and may be utilized. Upgrading to version 6.1.3 and 7.1.3 is able to address this issue. This patch is called 5bc698cef66f8abd12610dc623e5d67cbc0f869d. It is suggested to upgrade the affected component. The vendor explains, that according to his definition \"DoS on server-side on user-generated CSS is low risk for us (since most users compile own CSS with PostCSS).\" The commits were backported to 6.x branch, which was the most downloaded version.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"postcss-selector-parser AST Serialization container.js toString recursion","id":"CVE-2026-9358","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":4,"n_references":7,"next":{"headline":"Edimax EW-7438RPn POST Request formHwSet command injection","id":"CVE-2026-9359"},"packages":[{"ecosystem":"npm","fixed":["6.1.3"],"introduced":["6.1.0"],"last_affected":[],"package":"postcss-selector-parser","purl":null,"source":"GHSA-w9m9-85wc-3x92"},{"ecosystem":"npm","fixed":["6.1.3"],"introduced":["6.1.0"],"last_affected":[],"package":"postcss-selector-parser","purl":"pkg:npm/postcss-selector-parser","source":"GHSA-w9m9-85wc-3x92"},{"ecosystem":"npm","fixed":["7.1.3"],"introduced":["7.1.0"],"last_affected":[],"package":"postcss-selector-parser","purl":null,"source":"GHSA-w9m9-85wc-3x92"},{"ecosystem":"npm","fixed":["7.1.3"],"introduced":["7.1.0"],"last_affected":[],"package":"postcss-selector-parser","purl":"pkg:npm/postcss-selector-parser","source":"GHSA-w9m9-85wc-3x92"}],"prev":{"headline":"vBulletin Login cross site scripting","id":"CVE-2026-9357"},"products":["postcss-selector-parser"],"published":"2026-05-24","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-06-15","vendors":["n/a"]},"summary":"Remote attackers can cause denial of service via uncontrolled recursion in postcss-selector-parser's AST serialization, requiring an upgrade to fix.","url":"https://insights.sbomify.com/CVE-2026-9358/"}