CVE-2026-93587 ImageMagick before 7.1.2-31 Policy Bypass via PCD decoder

Medium 4.8 Published Updated

A local user can bypass ImageMagick memory policies via specific command line options in the PCD decoder, causing resource exhaustion and denial of service.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Local or same network only
Victim action needed
Not needed
Fix
Available

What is CVE-2026-93587?

CVE-2026-93587 is a medium-severity denial of service vulnerability in Imagemagick Imagemagick, published on 18 Sep 2026. It can only be exploited from the same machine or local network, with no action from the victim.

Official description

ImageMagick before 7.1.2-31 and before 6.9.13-56 contains a policy bypass in the PCD (and, per the upstream advisory, CUBE and HALD) coder: when a specific command line option is supplied, the decoder does not check a configured resource limit, which can result in extra memory allocation. A local user able to pass command line options to ImageMagick can therefore exceed the intended memory policy limit, causing a limited availability impact. The issue is fixed in 7.1.2-31 and 6.9.13-56.

Weakness: CWE-400

Which versions are affected by CVE-2026-93587?

It affects 1 product.

Products include Imagemagick Imagemagick.

How do I fix CVE-2026-93587?

Upgrade to a fixed version.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2026-93587 being exploited?

There is no known exploitation of CVE-2026-93587 in the wild and no public exploit code.

All Imagemagick Imagemagick vulnerabilities

Sources

Also known as DEBIAN-CVE-2026-93587, ECHO-abe5-0b50-28e6, GHSA-4pmj-hc43-8mwx, GHSA-89wq-f8f6-2j2v, MINI-cjhj-76pm-f843, UBUNTU-CVE-2026-93587.

Is CVE-2026-93587 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free