# CVE-2026-93592: vLLM before 0.28.0 Denial of Service via negative token ID

> Unauthenticated attackers can crash the vLLM inference engine by submitting negative token IDs, causing a denial of service until restart.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Sep 2026
- **Updated:** 18 Sep 2026
- **Also known as:** GHSA-25q3-v2hm-8vpf, GHSA-c3vq-r33v-49cr, MINI-27qv-wqcq-9f6r, MINI-3pxm-xj6f-4frv, MINI-mpwq-r93g-82r6, PYSEC-2026-3997

## What is CVE-2026-93592?

CVE-2026-93592 is a high-severity denial of service vulnerability in Vllm Vllm, published on 18 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

vLLM versions before 0.28.0 fail to validate the lower bound of token IDs in the /v1/embeddings and /pooling endpoints, allowing unauthenticated attackers to crash the engine by submitting negative token IDs. A single request with a negative token ID triggers a CUDA device-side assertion that poisons the GPU context, causing all subsequent requests to fail until the process restarts.

Weakness: CWE-129 (Improper Validation of Array Index)

## Which versions are affected by CVE-2026-93592?

1 open source package ship an affected version, including vllm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vllm` | PyPI | All versions | 0.28.0 |

Products: Vllm Vllm.

## How do I fix CVE-2026-93592?

Upgrade vllm to 0.28.0 or later.

## Is CVE-2026-93592 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-93592 exists.

## Other vulnerabilities in Vllm Vllm

- [CVE-2025-32444](https://insights.sbomify.com/CVE-2025-32444/): vLLM Vulnerable to Remote Code Execution via Mooncake Integration (critical 10.0)
- [CVE-2026-22778](https://insights.sbomify.com/CVE-2026-22778/): vLLM leaks a heap address when PIL throws an error (critical 9.8)
- [CVE-2025-47277](https://insights.sbomify.com/CVE-2025-47277/): vLLM Allows Remote Code Execution via PyNcclPipe Communication Service (critical 9.8)
- [CVE-2024-11041](https://insights.sbomify.com/CVE-2024-11041/): Remote Code Execution in vllm-project/vllm (critical 9.8)
- [CVE-2026-48746](https://insights.sbomify.com/CVE-2026-48746/): vLLM: OpenAI auth bypass (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-93592 and fix it if it is affected.

What it is: CVE-2026-93592 is a high-severity denial of service vulnerability in Vllm Vllm, published on 18 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-93592 exists.

Affected packages and fixed versions:
- vllm (PyPI): affected all versions; fixed in 0.28.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-93592/ (Markdown: https://insights.sbomify.com/CVE-2026-93592/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-93592
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-93592
- OSV: https://osv.dev/vulnerability/CVE-2026-93592

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-93592/
Summaries are generated and may contain mistakes; the official description above is the record.
