{"answers":{"affected":"","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-93598 exists.","fix":"No fix has been published for CVE-2026-93598 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-93598 is a high-severity vulnerability in ArcadeData arcadedb, published on 18 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-93598 and fix it if it is affected.\n\nWhat it is: CVE-2026-93598 is a high-severity vulnerability in ArcadeData arcadedb, published on 18 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-93598 exists.\n\nAffected product: ArcadeData arcadedb. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-93598/ (Markdown: https://insights.sbomify.com/CVE-2026-93598/index.md)","id":"CVE-2026-93598","markdown":"https://insights.sbomify.com/CVE-2026-93598/index.md","name":"CVE-2026-93598","record":{"aliases":["GHSA-j57p-qmrh-v7xv","GHSA-rqx6-fvpr-qm24"],"analysis":{"component_type":"database","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"ArcadeDB database","requires_auth":"low_privilege","summary":"A user with schema update privileges can bypass script sandbox restrictions to read classpath resources, potentially exposing database credentials and API keys.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[],"cvss":{"score":7.1,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-184","name":"Incomplete List of Disallowed Inputs"}],"description":"ArcadeDB (Maven artifact com.arcadedb:arcadedb-engine) through 26.8.1 contains an incomplete deny-list in the polyglot script sandbox: com.arcadedb.query.polyglot.HostClassLookupFilter.DENIED lists java.util.ResourceBundle as a bare class name, which is matched by exact equality and therefore does not cover its subclasses, while ScriptTriggerExecutor.ALLOWED_PACKAGES permits java.util.*. A user with the UPDATE_SCHEMA privilege (sufficient to create or alter a JavaScript trigger; no server-admin rights required) can reference java.util.PropertyResourceBundle or java.util.ListResourceBundle and invoke the inherited static ResourceBundle.getBundle(String) to read .properties resources from the application classpath, which the sandbox (IOAccess.NONE, with java.io.**, java.nio.** and java.net.** denied) is intended to make unreachable. This can disclose packaged application configuration such as database credentials and API keys; the advisory states the issue does not provide arbitrary host filesystem read or remote code execution. Fixed in 26.9.1.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":false,"headline":"ArcadeDB before 26.9.1 Classpath Credential Disclosure via ResourceBundle","id":"CVE-2026-93598","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"information_disclosure","year":"2026"},"n_packages":0,"n_references":2,"next":{"headline":"rustls-webpki before 0.103.13 Panic via empty BIT STRING","id":"CVE-2026-93599"},"packages":[],"prev":{"headline":"ArcadeDB before 26.9.1 SSRF via IPv6 transition addresses","id":"CVE-2026-93597"},"products":["arcadedb"],"published":"2026-09-18","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-09-22","vendors":["ArcadeData"]},"summary":"A user with schema update privileges can bypass script sandbox restrictions to read classpath resources, potentially exposing database credentials and API keys.","url":"https://insights.sbomify.com/CVE-2026-93598/"}