# CVE-2026-93600: rustls webpki Name Constraints URI Validation Bypass

> Attackers can bypass X.509 URI name constraints in rustls-webpki using misissued certificates, undermining certificate validation security.

- **Severity:** Low 2.1 (`CVSS:4.0/AV:N/AC:H/AT:P/PR:H/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Sep 2026
- **Updated:** 21 Sep 2026
- **Also known as:** AZL-103466, AZL-103496, AZL-103515, AZL-103527, CLEANSTART-2026-SK45951, DEBIAN-CVE-2026-93600, GHSA-965h-392x-2mh5, GHSA-fr4g-m728-g2mf, MINI-24x4-jp8f-6cc2, MINI-2cjj-pgjc-m4r6, MINI-2jm2-6jvm-p8mq, MINI-33qx-cw2q-32xh, MINI-3w6w-47v2-7hf2, MINI-6356-fph4-9m77, MINI-6h7j-rj8w-m688, MINI-6v5m-48jc-2x4f, MINI-82fg-qg27-q6mh, MINI-836h-5x8q-2xvx, MINI-8855-m48x-p88v, MINI-9735-2xr7-whhg, MINI-c5p3-7773-r7cj, MINI-fhjc-vp82-hcwq, MINI-frcw-xfjh-985v, MINI-j9h8-x524-5r5q, MINI-jc8x-fh94-2fqq, MINI-m2pg-ww6r-qf3j, MINI-m4gm-935g-9hrw, MINI-mmcm-8wh4-w5r8, MINI-qxxh-24g8-4v6x, MINI-v476-h3mx-f249, MINI-xf3p-9q8g-pr65, MINI-xq4r-5238-jf9v, RUSTSEC-2026-0098, UBUNTU-CVE-2026-93600

## What is CVE-2026-93600?

CVE-2026-93600 is a low-severity vulnerability in rustls webpki, published on 18 Sep 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

rustls-webpki (rustls/webpki) versions 0.101.0 through 0.103.11 and 0.104.0-alpha releases before 0.104.0-alpha.6 ignore X.509 name constraints that apply to URI names, causing such constraints to be accepted rather than enforced. Because name constraints are restrictions on otherwise properly issued certificates, the flaw is only reachable after successful signature verification and requires a misissued certificate to exploit; the library also provides no API for asserting URI names, and URI name constraints are otherwise unimplemented. Versions 0.103.12 and 0.104.0-alpha.6 reject URI name constraints unconditionally.

Weakness: CWE-295 (Improper Certificate Validation)

## Which versions are affected by CVE-2026-93600?

5 open source packages ship an affected version, including rustls-webpki.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `rustls-webpki` | crates.io | From 0.0.0-0 | 0.103.12, 0.104.0-alpha.6 |
| `rustls-webpki` | crates.io | From 0.101.0 | 0.103.12 |
| `rustls-webpki` | crates.io | From 0.101.0 | 0.103.12 |
| `rustls-webpki` | crates.io | From 0.104.0-alpha.1 | 0.104.0-alpha.6 |
| `rustls-webpki` | crates.io | From 0.104.0-alpha.1 | 0.104.0-alpha.6 |

## How do I fix CVE-2026-93600?

Upgrade rustls-webpki to a fixed version for your release line: 0.103.12 or 0.104.0-alpha.6.

## Is CVE-2026-93600 being exploited?

There is no known exploitation of CVE-2026-93600 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-93600 and fix it if it is affected.

What it is: CVE-2026-93600 is a low-severity vulnerability in rustls webpki, published on 18 Sep 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-93600 in the wild and no public exploit code.

Affected packages and fixed versions:
- rustls-webpki (crates.io): affected from 0.0.0-0; fixed in 0.103.12, 0.104.0-alpha.6
- rustls-webpki (crates.io): affected from 0.101.0; fixed in 0.103.12
- rustls-webpki (crates.io): affected from 0.101.0; fixed in 0.103.12
- rustls-webpki (crates.io): affected from 0.104.0-alpha.1; fixed in 0.104.0-alpha.6
- rustls-webpki (crates.io): affected from 0.104.0-alpha.1; fixed in 0.104.0-alpha.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-93600/ (Markdown: https://insights.sbomify.com/CVE-2026-93600/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-93600
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-93600
- OSV: https://osv.dev/vulnerability/CVE-2026-93600

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-93600/
Summaries are generated and may contain mistakes; the official description above is the record.
