# CVE-2026-93601: rustls webpki 0.101.0 before 0.103.12 Name Constraint Bypass

> An attacker with a misissued wildcard certificate can bypass DNS name constraints in rustls-webpki, potentially allowing unauthorized certificate acceptance.

- **Severity:** Low 2.1 (`CVSS:4.0/AV:N/AC:H/AT:P/PR:H/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Sep 2026
- **Updated:** 18 Sep 2026
- **Also known as:** AZL-103460, AZL-103500, AZL-103509, AZL-103521, CLEANSTART-2026-PO20048, DEBIAN-CVE-2026-93601, GHSA-27hx-xqx9-p6hq, GHSA-xgp8-3hg3-c2mh, MINI-2pj3-jvw8-q8mc, MINI-385q-fcrf-8gr8, MINI-47px-xqhg-xj38, MINI-5c25-rg29-78cw, MINI-67x9-xgv8-p736, MINI-6c83-j9m3-f56h, MINI-6f98-hpm5-8pp3, MINI-7mq7-prg4-xh8v, MINI-7r39-9h76-mwwr, MINI-89m9-2cg6-jvwx, MINI-8vhx-793r-r9rw, MINI-ccr6-mwgm-pwrq, MINI-chr9-7ggp-3r3w, MINI-cpr5-q7vr-r9xm, MINI-f9q6-grjq-7pvg, MINI-gfrv-mrv2-7r3p, MINI-h7pq-cpwx-x43m, MINI-h87x-wmhr-8g5g, MINI-hm2g-mfqp-hmc2, MINI-j8ch-xf4f-vc54, MINI-pffm-2528-6m66, MINI-q9mx-3v56-5p5w, MINI-w26h-hq48-8gmc, MINI-x52j-6xv9-hxpr, RUSTSEC-2026-0099, UBUNTU-CVE-2026-93601

## What is CVE-2026-93601?

CVE-2026-93601 is a low-severity vulnerability in rustls webpki, published on 18 Sep 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

rustls-webpki (the Rust webpki fork used by rustls) versions >= 0.101.0 and prior to 0.103.12 and 0.104.0-alpha.6 incorrectly accepted permitted-subtree DNS name constraints for certificates asserting a wildcard name. For example, a name constraint of accept.example.com was treated as satisfied by a certificate for *.example.com, which could feasibly assert reject.example.com — a name outside the permitted subtree. Because name constraints are restrictions applied to otherwise properly issued certificates, the issue is only reachable after signature verification succeeds and requires a misissued wildcard certificate to exploit.

Weakness: CWE-295 (Improper Certificate Validation)

## Which versions are affected by CVE-2026-93601?

5 open source packages ship an affected version, including rustls-webpki.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `rustls-webpki` | crates.io | From 0.0.0-0 | 0.103.12, 0.104.0-alpha.6 |
| `rustls-webpki` | crates.io | From 0.101.0 | 0.103.12 |
| `rustls-webpki` | crates.io | From 0.101.0 | 0.103.12 |
| `rustls-webpki` | crates.io | From 0.104.0-alpha.1 | 0.104.0-alpha.6 |
| `rustls-webpki` | crates.io | From 0.104.0-alpha.1 | 0.104.0-alpha.6 |

## How do I fix CVE-2026-93601?

Upgrade rustls-webpki to a fixed version for your release line: 0.103.12 or 0.104.0-alpha.6.

## Is CVE-2026-93601 being exploited?

There is no known exploitation of CVE-2026-93601 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-93601 and fix it if it is affected.

What it is: CVE-2026-93601 is a low-severity vulnerability in rustls webpki, published on 18 Sep 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-93601 in the wild and no public exploit code.

Affected packages and fixed versions:
- rustls-webpki (crates.io): affected from 0.0.0-0; fixed in 0.103.12, 0.104.0-alpha.6
- rustls-webpki (crates.io): affected from 0.101.0; fixed in 0.103.12
- rustls-webpki (crates.io): affected from 0.101.0; fixed in 0.103.12
- rustls-webpki (crates.io): affected from 0.104.0-alpha.1; fixed in 0.104.0-alpha.6
- rustls-webpki (crates.io): affected from 0.104.0-alpha.1; fixed in 0.104.0-alpha.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-93601/ (Markdown: https://insights.sbomify.com/CVE-2026-93601/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-93601
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-93601
- OSV: https://osv.dev/vulnerability/CVE-2026-93601

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-93601/
Summaries are generated and may contain mistakes; the official description above is the record.
