# CVE-2026-93602: rustls-webpki before 0.103.10 CRL Revocation Check Bypass

> Attackers with a compromised CA can bypass CRL revocation checks in rustls-webpki, allowing revoked certificates to be accepted.

- **Severity:** Medium 5.9 (`CVSS:4.0/AV:N/AC:H/AT:P/PR:H/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Sep 2026
- **Updated:** 18 Sep 2026
- **Also known as:** AZL-103463, AZL-103503, AZL-103511, AZL-103524, CLEANSTART-2026-XA32813, DEBIAN-CVE-2026-93602, GHSA-8hrm-p5h4-6vcx, GHSA-pwjx-qhcg-rvj4, MINI-282f-qvjf-gxrr, MINI-36r4-gjmp-v757, MINI-4745-cj29-4r3c, MINI-5g48-p755-pjmf, MINI-5pw2-2c8h-3w7v, MINI-64h2-q2x3-g776, MINI-68w2-c9j7-hvj7, MINI-6r9r-mv59-pvc8, MINI-7h35-4hf2-c82c, MINI-9mmv-2m75-cjfq, MINI-cx84-gqpx-v45c, MINI-fhqm-m7xq-6cf8, MINI-gr9x-w7g6-5j7j, MINI-gwjf-27qf-2whw, MINI-j9vp-2427-372r, MINI-jmwj-r66w-m859, MINI-jpf9-768x-9xx6, MINI-mj6f-4h5m-4396, MINI-qr44-6pw5-8qrm, MINI-vg62-5qj5-2rmv, MINI-wqp9-8qv3-jwfx, MINI-xhq3-2pgv-p2w3, RUSTSEC-2026-0049, UBUNTU-CVE-2026-93602

## What is CVE-2026-93602?

CVE-2026-93602 is a medium-severity vulnerability in rustls webpki, published on 18 Sep 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

rustls-webpki versions before 0.103.10 and 0.104.0-alpha.5 contain faulty CRL authority-matching logic that compares only the first distributionPoint against each CRL's IssuingDistributionPoint, ignoring additional distributionPoints. Attackers with a compromised trusted issuing authority can present revoked certificates that pass revocation checks under UnknownStatusPolicy::Allow, or cause incorrect errors under the default deny policy.

Weakness: CWE-299 (Improper Check for Certificate Revocation)

## Which versions are affected by CVE-2026-93602?

5 open source packages ship an affected version, including rustls-webpki.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `rustls-webpki` | crates.io | From 0.102.0-alpha.0 | 0.103.10 |
| `rustls-webpki` | crates.io | From 0.102.0-alpha.0 | 0.103.10 |
| `rustls-webpki` | crates.io | From 0.102.0-alpha.0 | 0.103.10 |
| `rustls-webpki` | crates.io | From 0.104.0-alpha.1 | 0.104.0-alpha.5 |
| `rustls-webpki` | crates.io | From 0.104.0-alpha.1 | 0.104.0-alpha.5 |

## How do I fix CVE-2026-93602?

Upgrade rustls-webpki to a fixed version for your release line: 0.103.10 or 0.104.0-alpha.5.

## Is CVE-2026-93602 being exploited?

There is no known exploitation of CVE-2026-93602 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-93602 and fix it if it is affected.

What it is: CVE-2026-93602 is a medium-severity vulnerability in rustls webpki, published on 18 Sep 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-93602 in the wild and no public exploit code.

Affected packages and fixed versions:
- rustls-webpki (crates.io): affected from 0.102.0-alpha.0; fixed in 0.103.10
- rustls-webpki (crates.io): affected from 0.102.0-alpha.0; fixed in 0.103.10
- rustls-webpki (crates.io): affected from 0.102.0-alpha.0; fixed in 0.103.10
- rustls-webpki (crates.io): affected from 0.104.0-alpha.1; fixed in 0.104.0-alpha.5
- rustls-webpki (crates.io): affected from 0.104.0-alpha.1; fixed in 0.104.0-alpha.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-93602/ (Markdown: https://insights.sbomify.com/CVE-2026-93602/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-93602
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-93602
- OSV: https://osv.dev/vulnerability/CVE-2026-93602

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-93602/
Summaries are generated and may contain mistakes; the official description above is the record.
