# CVE-2026-93603: vm2 before 3.12.1 Sandbox Escape RCE via Non-Strict Host Function

> Attackers can escape the vm2 sandbox and execute arbitrary code on the host if the application exposes non-strict host functions to untrusted scripts.

- **Severity:** Critical 10.0 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 18 Sep 2026
- **Updated:** 22 Sep 2026
- **Also known as:** GHSA-2mqq-5j76-f3c6, GHSA-j89j-5m6r-cr2q

## What is CVE-2026-93603?

CVE-2026-93603 is a critical code injection vulnerability in patriksimek vm2, published on 18 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

vm2 through 3.12.0 (fixed in 3.12.1) does not correctly handle a nullish `this` receiver in the apply trap of its bridge (lib/bridge.js): when sandboxed code calls a host-provided non-strict (sloppy-mode) function without a receiver — e.g. `fn()`, a detached method, `fn.call()`, `fn.apply(undefined)`, `Reflect.apply(fn, undefined, [])`, or `fn.bind()()` — the undefined receiver is passed straight through to the host call, and V8 substitutes the host realm's global object for `this`. vm2 then wraps and returns that object to the sandbox, giving sandboxed script a live proxy of the host global. This allows a complete sandbox escape: untrusted script can reach `process` and execute arbitrary code/commands on the host (for example via `process.getBuiltinModule('child_process').execSync`). Exploitation requires that the embedding application expose at least one non-strict host function to the sandbox; strict-mode and ES module host functions are not affected.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2026-93603?


## How do I fix CVE-2026-93603?

No fix has been published for CVE-2026-93603 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-93603 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-93603 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-93603 and fix it if it is affected.

What it is: CVE-2026-93603 is a critical code injection vulnerability in patriksimek vm2, published on 18 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-93603 exists.

Affected product: patriksimek vm2. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-93603/ (Markdown: https://insights.sbomify.com/CVE-2026-93603/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-93603
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-93603
- OSV: https://osv.dev/vulnerability/CVE-2026-93603

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-93603/
Summaries are generated and may contain mistakes; the official description above is the record.
