# CVE-2026-93605: vm2 NodeVM before 3.12.1 Remote Code Execution via child_process

> Attackers can execute arbitrary commands on the host system by bypassing the vm2 sandbox when child_process is allowed.

- **Severity:** Critical 10.0 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Sep 2026
- **Updated:** 21 Sep 2026
- **Also known as:** CLSA-2026-1791626237, CLSA-2026-1791666662, ECHO-bc31-8f22-cdd1, GHSA-pq68-rvw4-xp4r, MINI-wr7h-x422-3fvw, ROOT-APP-NPM-CVE-2026-93605

## What is CVE-2026-93605?

CVE-2026-93605 is a critical code injection vulnerability in patriksimek vm2, published on 18 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

vm2 NodeVM versions before 3.12.1 contain a sandbox escape vulnerability where the DANGEROUS_BUILTINS denylist omits child_process despite blocking other host-spawning modules. Attackers can require child_process and execute arbitrary commands on the host system when NodeVM is configured with builtin:['*'] or explicit child_process allowance.

Weakness: CWE-693 (Protection Mechanism Failure)

## Which versions are affected by CVE-2026-93605?

2 open source packages ship an affected version, including vm2.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vm2` | npm | All versions | 3.12.1 |
| `vm2` | npm | All versions | 3.12.1 |

## How do I fix CVE-2026-93605?

Upgrade vm2 to 3.12.1 or later.

## Is CVE-2026-93605 being exploited?

There is no known exploitation of CVE-2026-93605 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-93605 and fix it if it is affected.

What it is: CVE-2026-93605 is a critical code injection vulnerability in patriksimek vm2, published on 18 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-93605 in the wild and no public exploit code.

Affected packages and fixed versions:
- vm2 (npm): affected all versions; fixed in 3.12.1
- vm2 (npm): affected all versions; fixed in 3.12.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-93605/ (Markdown: https://insights.sbomify.com/CVE-2026-93605/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-93605
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-93605
- OSV: https://osv.dev/vulnerability/CVE-2026-93605

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-93605/
Summaries are generated and may contain mistakes; the official description above is the record.
