CVE-2026-9365 Ettercap GG Dissector ec_gg.c FUNC_DECODER heap-based overflow

Medium 6.3 Published Updated

Remote attackers can trigger a heap-based buffer overflow in Ettercap's GG Dissector, potentially leading to code execution or service disruption.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2026-9365?

CVE-2026-9365 is a medium-severity memory corruption vulnerability in Ettercap, published on 24 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

A vulnerability has been found in Ettercap up to 0.8.3. The affected element is the function FUNC_DECODER of the file src/dissectors/ec_gg.c of the component GG Dissector. The manipulation of the argument gg leads to heap-based buffer overflow. The attack is possible to be carried out remotely. The complexity of an attack is rather high. The exploitability is described as difficult. The exploit has been disclosed to the public and may be used. Upgrading to version 0.8.4 is sufficient to fix this issue. The identifier of the patch is feeae6fa366e01a3dd9f1857ec6aae847b2ae00c. It is suggested to upgrade the affected component.

Weakness: CWE-122, CWE-119

Which versions are affected by CVE-2026-9365?

How do I fix CVE-2026-9365?

No fix has been published for CVE-2026-9365 yet. Limit exposure of the affected software until one is available.

Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.

Is CVE-2026-9365 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-9365 exists.

Sources

Also known as DEBIAN-CVE-2026-9365, GHSA-fgvc-qw77-cmcj, UBUNTU-CVE-2026-9365.

Is CVE-2026-9365 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free