# CVE-2026-9365: Ettercap GG Dissector ec_gg.c FUNC_DECODER heap-based overflow

> Remote attackers can trigger a heap-based buffer overflow in Ettercap's GG Dissector, potentially leading to code execution or service disruption.

- **Severity:** Medium 6.3 (`CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 24 May 2026
- **Updated:** 26 May 2026
- **Also known as:** DEBIAN-CVE-2026-9365, GHSA-fgvc-qw77-cmcj, UBUNTU-CVE-2026-9365

## What is CVE-2026-9365?

CVE-2026-9365 is a medium-severity memory corruption vulnerability in Ettercap, published on 24 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A vulnerability has been found in Ettercap up to 0.8.3. The affected element is the function FUNC_DECODER of the file src/dissectors/ec_gg.c of the component GG Dissector. The manipulation of the argument gg leads to heap-based buffer overflow. The attack is possible to be carried out remotely. The complexity of an attack is rather high. The exploitability is described as difficult. The exploit has been disclosed to the public and may be used. Upgrading to version 0.8.4 is sufficient to fix this issue. The identifier of the patch is feeae6fa366e01a3dd9f1857ec6aae847b2ae00c. It is suggested to upgrade the affected component.

Weakness: CWE-122 (Heap-based Buffer Overflow), CWE-119 (Improper Restriction of Operations within the Bounds of a Memory Buffer)

## Which versions are affected by CVE-2026-9365?


## How do I fix CVE-2026-9365?

No fix has been published for CVE-2026-9365 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-9365 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-9365 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-9365 and fix it if it is affected.

What it is: CVE-2026-9365 is a medium-severity memory corruption vulnerability in Ettercap, published on 24 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-9365 exists.

Affected product: Ettercap. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-9365/ (Markdown: https://insights.sbomify.com/CVE-2026-9365/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-9365
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-9365
- OSV: https://osv.dev/vulnerability/CVE-2026-9365

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-9365/
Summaries are generated and may contain mistakes; the official description above is the record.
