# CVE-2026-93657: hickory-resolver before 0.26.2 DNSSEC Validation Bypass

> Attackers can bypass DNSSEC validation in hickory-resolver, causing forged DNS records to be accepted as valid by applications using the library.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Sep 2026
- **Updated:** 21 Sep 2026
- **Also known as:** DEBIAN-CVE-2026-93657, GHSA-5j98-2g5x-46v6, GHSA-884w-h442-q7ph, MINI-4qqv-5v7v-rhj5, MINI-79pv-pf94-mj5h, MINI-85w9-8m26-4phr, MINI-8rwr-g737-x432, MINI-8rxj-4v4v-9p7x, MINI-9h5f-qmwr-hcmh, MINI-m64w-h6rx-q4w5, MINI-m6rx-jcwm-fp8v, MINI-mq2p-h54g-993m, MINI-qcr4-3x4p-wv4p, MINI-r636-xvr4-h9m4, MINI-vmgr-6rxq-p2qv, MINI-vrmc-f86q-mwxq, MINI-ww6v-59j8-7crc, MINI-wwhr-2h3x-6gp6, MINI-xqfh-x4v3-jq4r, UBUNTU-CVE-2026-93657

## What is CVE-2026-93657?

CVE-2026-93657 is a high-severity vulnerability in hickory-dns hickory-resolver, published on 18 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

hickory-resolver versions before 0.26.2 fail to propagate bogus DNSSEC proof states through the Resolver::lookup() and Resolver::lookup_ip() APIs, allowing invalid records to be returned as successful results. Attackers controlling the answering zone or positioned on the network path can have forged DNS records accepted as validated, bypassing DNSSEC authentication checks.

Weakness: CWE-347 (Improper Verification of Cryptographic Signature)

## Which versions are affected by CVE-2026-93657?

2 open source packages ship an affected version, including hickory-resolver.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `hickory-resolver` | crates.io | All versions | 0.26.2 |
| `hickory-resolver` | crates.io | All versions | 0.26.2 |

## How do I fix CVE-2026-93657?

Upgrade hickory-resolver to 0.26.2 or later.

## Is CVE-2026-93657 being exploited?

There is no known exploitation of CVE-2026-93657 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-93657 and fix it if it is affected.

What it is: CVE-2026-93657 is a high-severity vulnerability in hickory-dns hickory-resolver, published on 18 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-93657 in the wild and no public exploit code.

Affected packages and fixed versions:
- hickory-resolver (crates.io): affected all versions; fixed in 0.26.2
- hickory-resolver (crates.io): affected all versions; fixed in 0.26.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-93657/ (Markdown: https://insights.sbomify.com/CVE-2026-93657/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-93657
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-93657
- OSV: https://osv.dev/vulnerability/CVE-2026-93657

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-93657/
Summaries are generated and may contain mistakes; the official description above is the record.
