# CVE-2026-9366: NousResearch hermes-agent prompt_builder.py _scan_context_content injection

> Remote attackers can inject code via the _scan_context_content function in the hermes-agent library, potentially leading to arbitrary code execution.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 May 2026
- **Updated:** 27 May 2026
- **Also known as:** GHSA-pgp4-xr4j-h5cg, PYSEC-2026-2514

## What is CVE-2026-9366?

CVE-2026-9366 is a medium-severity code injection vulnerability in NousResearch hermes-agent, published on 24 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A vulnerability was found in NousResearch hermes-agent 2026.4.23. The impacted element is the function _scan_context_content of the file agent/prompt_builder.py. The manipulation results in injection. The attack may be performed from remote. The exploit has been made public and could be used. The vendor was contacted early about this disclosure but did not respond in any way.

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component), CWE-707 (Improper Neutralization)

## Which versions are affected by CVE-2026-9366?

3 open source packages ship an affected version, including hermes-agent.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `hermes-agent` | PyPI | All versions | 0.15.0 |
| `hermes-agent` | PyPI | All versions | 0.15.0 |
| `hermes-agent` | PyPI | All versions | 0.15.0 |

## How do I fix CVE-2026-9366?

Upgrade hermes-agent to 0.15.0 or later.

## Is CVE-2026-9366 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-9366 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-9366 and fix it if it is affected.

What it is: CVE-2026-9366 is a medium-severity code injection vulnerability in NousResearch hermes-agent, published on 24 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-9366 exists.

Affected packages and fixed versions:
- hermes-agent (PyPI): affected all versions; fixed in 0.15.0
- hermes-agent (PyPI): affected all versions; fixed in 0.15.0
- hermes-agent (PyPI): affected all versions; fixed in 0.15.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-9366/ (Markdown: https://insights.sbomify.com/CVE-2026-9366/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-9366
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-9366
- OSV: https://osv.dev/vulnerability/CVE-2026-9366

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-9366/
Summaries are generated and may contain mistakes; the official description above is the record.
