# CVE-2026-9368: NousResearch hermes-agent Environment Variable code_execution_tool.py execute_code sandbox

> Remote attackers can bypass the code execution sandbox in NousResearch hermes-agent to execute arbitrary code and escalate privileges.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 May 2026
- **Updated:** 26 May 2026
- **Also known as:** GHSA-wm96-9gfh-vvgq, PYSEC-2026-2515

## What is CVE-2026-9368?

CVE-2026-9368 is a medium-severity code injection vulnerability in NousResearch hermes-agent, published on 24 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A vulnerability was identified in NousResearch hermes-agent up to 2026.4.16. This impacts the function execute_code of the file tools/code_execution_tool.py of the component Environment Variable Handler. Such manipulation leads to sandbox issue. It is possible to launch the attack remotely. The exploit is publicly available and might be used. The vendor was contacted early about this disclosure but did not respond in any way.

Weakness: CWE-265, CWE-264

## Which versions are affected by CVE-2026-9368?

3 open source packages ship an affected version, including hermes-agent.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `hermes-agent` | PyPI | All versions | 0.11.0 |
| `hermes-agent` | PyPI | All versions | 0.11.0 |
| `hermes-agent` | PyPI | All versions | 0.11.0 |

## How do I fix CVE-2026-9368?

Upgrade hermes-agent to 0.11.0 or later.

## Is CVE-2026-9368 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-9368 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-9368 and fix it if it is affected.

What it is: CVE-2026-9368 is a medium-severity code injection vulnerability in NousResearch hermes-agent, published on 24 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-9368 exists.

Affected packages and fixed versions:
- hermes-agent (PyPI): affected all versions; fixed in 0.11.0
- hermes-agent (PyPI): affected all versions; fixed in 0.11.0
- hermes-agent (PyPI): affected all versions; fixed in 0.11.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-9368/ (Markdown: https://insights.sbomify.com/CVE-2026-9368/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-9368
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-9368
- OSV: https://osv.dev/vulnerability/CVE-2026-9368

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-9368/
Summaries are generated and may contain mistakes; the official description above is the record.
