CVE-2026-93684 Apache Impala: Stored XSS in Impala query plans

Medium 5.4 Published Updated

An attacker with SELECT permissions can inject JavaScript into table aliases, executing it in other users' browsers via the Impala Web UI.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
None listed

What is CVE-2026-93684?

CVE-2026-93684 is a medium-severity cross-site scripting vulnerability in Apache Impala, published on 7 Oct 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

An SQL user using Impala up to and including version 4.5.2 with only SELECT permission can put JavaScript in a table alias and make it run in another user's browser when that user opens the query plan in Impala's Web UI. This is stored XSS (CWE-79). Users are recommended to upgrade to version 4.5.3.

Weakness: CWE-79

Which versions are affected by CVE-2026-93684?

How do I fix CVE-2026-93684?

No fix has been published for CVE-2026-93684 yet. Limit exposure of the affected software until one is available.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2026-93684 being exploited?

There is no known exploitation of CVE-2026-93684 in the wild and no public exploit code.

Sources

Also known as GHSA-gr7f-9f5r-v3mg.

Is CVE-2026-93684 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free