{"answers":{"affected":"2 open source packages ship an affected version, including source-map-js.","exploited":"There is no known exploitation of CVE-2026-93749 in the wild and no public exploit code.","fix":"Upgrade source-map-js to 1.2.2 or later.","what":"CVE-2026-93749 is a high-severity denial of service vulnerability in 7rulnik source-map-js, published on 18 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-93749 and fix it if it is affected.\n\nWhat it is: CVE-2026-93749 is a high-severity denial of service vulnerability in 7rulnik source-map-js, published on 18 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-93749 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- source-map-js (npm): affected from 1.0.0; fixed in 1.2.2\n- source-map-js (npm): affected from 1.0.0; fixed in 1.2.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-93749/ (Markdown: https://insights.sbomify.com/CVE-2026-93749/index.md)","id":"CVE-2026-93749","markdown":"https://insights.sbomify.com/CVE-2026-93749/index.md","name":"CVE-2026-93749","record":{"aliases":["AZL-103442","AZL-103478","CLEANSTART-2026-AC91052","CLEANSTART-2026-ME02070","CLEANSTART-2026-VU21760","CLEANSTART-2026-XM40960","CLSA-2026-1792668516","DEBIAN-CVE-2026-93749","ECHO-6bdc-e3c3-0ffd","GHSA-68fv-2mgg-jv7q","MINI-3cjg-v88x-fhv2","MINI-4qcw-r4h7-qrq5","MINI-5fjq-5w3w-77c9","MINI-87fv-r7px-hjff","MINI-f884-259p-7gj8","MINI-g57x-p6w6-j3qx","MINI-jfmr-jj2j-4mhw","MINI-jhjr-5f3c-v3f7","MINI-p7pq-6fxr-9cx5","MINI-v26w-f5c5-mxhh","MINI-wjh8-9h7j-rrm4","MINI-x554-qwhc-gqrj","MINI-xxj8-qvpj-f88x","ROOT-APP-NPM-CVE-2026-93749","UBUNTU-CVE-2026-93749"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"JavaScript source map library","requires_auth":"none","summary":"Attackers can cause denial of service by supplying large offset values in source maps, blocking the event loop in applications using source-map-js.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[],"cvss":{"score":8.7,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-1284","name":"Improper Validation of Specified Quantity in Input"}],"description":"source-map-js through 1.2.1 fails to validate the per-section offset line value in indexed source maps, allowing attackers to specify arbitrary numeric values. Attackers can supply extremely large offset line values that cause synchronous event loop blocking for extended periods, preventing the service from handling other requests.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"source-map-js through 1.2.1 Event Loop Denial of Service","id":"CVE-2026-93749","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":2,"n_references":4,"next":{"headline":"http-cache-semantics through 4.2.0 Cross-Client Cache Disclosure via Vary Wildcard","id":"CVE-2026-93750"},"packages":[{"ecosystem":"npm","fixed":["1.2.2"],"introduced":["1.0.0"],"last_affected":[],"package":"source-map-js","purl":null,"source":"GHSA-68fv-2mgg-jv7q"},{"ecosystem":"npm","fixed":["1.2.2"],"introduced":["1.0.0"],"last_affected":[],"package":"source-map-js","purl":"pkg:npm/source-map-js","source":"GHSA-68fv-2mgg-jv7q"}],"prev":{"headline":"http-cache-semantics through 4.2.0 Cross-User Cache Disclosure via max-stale","id":"CVE-2026-93748"},"products":["source-map-js"],"published":"2026-09-18","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-09-24","vendors":["7rulnik"]},"summary":"Attackers can cause denial of service by supplying large offset values in source maps, blocking the event loop in applications using source-map-js.","url":"https://insights.sbomify.com/CVE-2026-93749/"}