# CVE-2026-93749: source-map-js through 1.2.1 Event Loop Denial of Service

> Attackers can cause denial of service by supplying large offset values in source maps, blocking the event loop in applications using source-map-js.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Sep 2026
- **Updated:** 24 Sep 2026
- **Also known as:** AZL-103442, AZL-103478, CLEANSTART-2026-AC91052, CLEANSTART-2026-ME02070, CLEANSTART-2026-VU21760, CLEANSTART-2026-XM40960, CLSA-2026-1792668516, DEBIAN-CVE-2026-93749, ECHO-6bdc-e3c3-0ffd, GHSA-68fv-2mgg-jv7q, MINI-3cjg-v88x-fhv2, MINI-4qcw-r4h7-qrq5, MINI-5fjq-5w3w-77c9, MINI-87fv-r7px-hjff, MINI-f884-259p-7gj8, MINI-g57x-p6w6-j3qx, MINI-jfmr-jj2j-4mhw, MINI-jhjr-5f3c-v3f7, MINI-p7pq-6fxr-9cx5, MINI-v26w-f5c5-mxhh, MINI-wjh8-9h7j-rrm4, MINI-x554-qwhc-gqrj, MINI-xxj8-qvpj-f88x, ROOT-APP-NPM-CVE-2026-93749, UBUNTU-CVE-2026-93749

## What is CVE-2026-93749?

CVE-2026-93749 is a high-severity denial of service vulnerability in 7rulnik source-map-js, published on 18 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

source-map-js through 1.2.1 fails to validate the per-section offset line value in indexed source maps, allowing attackers to specify arbitrary numeric values. Attackers can supply extremely large offset line values that cause synchronous event loop blocking for extended periods, preventing the service from handling other requests.

Weakness: CWE-1284 (Improper Validation of Specified Quantity in Input)

## Which versions are affected by CVE-2026-93749?

2 open source packages ship an affected version, including source-map-js.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `source-map-js` | npm | From 1.0.0 | 1.2.2 |
| `source-map-js` | npm | From 1.0.0 | 1.2.2 |

## How do I fix CVE-2026-93749?

Upgrade source-map-js to 1.2.2 or later.

## Is CVE-2026-93749 being exploited?

There is no known exploitation of CVE-2026-93749 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-93749 and fix it if it is affected.

What it is: CVE-2026-93749 is a high-severity denial of service vulnerability in 7rulnik source-map-js, published on 18 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-93749 in the wild and no public exploit code.

Affected packages and fixed versions:
- source-map-js (npm): affected from 1.0.0; fixed in 1.2.2
- source-map-js (npm): affected from 1.0.0; fixed in 1.2.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-93749/ (Markdown: https://insights.sbomify.com/CVE-2026-93749/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-93749
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-93749
- OSV: https://osv.dev/vulnerability/CVE-2026-93749

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-93749/
Summaries are generated and may contain mistakes; the official description above is the record.
