{"answers":{"affected":"2 open source packages ship an affected version, including deepmerge.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-93753 exists.","fix":"Upgrade to a fixed version.","what":"CVE-2026-93753 is a high-severity vulnerability in TehShrike deepmerge, published on 18 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-93753 and fix it if it is affected.\n\nWhat it is: CVE-2026-93753 is a high-severity vulnerability in TehShrike deepmerge, published on 18 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-93753 exists.\n\nAffected packages and fixed versions:\n- deepmerge (npm): affected from 4.2.0 up to 4.3.1; no fix listed\n- deepmerge (npm): affected from 4.2.0 up to 4.3.1; no fix listed\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-93753/ (Markdown: https://insights.sbomify.com/CVE-2026-93753/index.md)","id":"CVE-2026-93753","markdown":"https://insights.sbomify.com/CVE-2026-93753/index.md","name":"CVE-2026-93753","record":{"aliases":["DEBIAN-CVE-2026-93753","GHSA-gcqx-w48m-w2h4","MINI-3hrf-5869-gx4x","MINI-3qcp-6vx6-5xc8","MINI-c3jq-hxm4-v8xr","MINI-cj6w-h26h-g657","MINI-cqc8-f9wj-82mr","MINI-qpxg-f4g5-mvv5","UBUNTU-CVE-2026-93753","openSUSE-SU-2026:12285-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"JavaScript deepmerge library","requires_auth":"none","summary":"Attackers can inject properties into object prototypes via merge operations, potentially leading to code execution or privilege escalation in applications using the library.","user_interaction":"not_required","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[],"cvss":{"score":8.7,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-1321","name":"Improperly Controlled Modification of Object Prototype Attributes"}],"description":"deepmerge through 4.3.1 contains a prototype poisoning vulnerability in the mergeObject() function that fails to properly validate keys being written to target objects. Attackers can supply malicious source objects in merge operations to inject attacker-controlled properties into the returned object's prototype, causing applications to inherit unintended values when accessing properties without own-property checks.","ecosystems":["npm","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"deepmerge through 4.3.1 Prototype Poisoning via mergeObject","id":"CVE-2026-93753","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"other","year":"2026"},"n_packages":3,"n_references":4,"next":{"headline":"Cross-site scripting in Smash Balloon Social Post Feed – Simple Social Feeds for WordPress","id":"CVE-2026-93756"},"packages":[{"ecosystem":"npm","fixed":[],"introduced":["4.2.0"],"last_affected":["4.3.1"],"package":"deepmerge","purl":null,"source":"GHSA-gcqx-w48m-w2h4"},{"ecosystem":"npm","fixed":[],"introduced":["4.2.0"],"last_affected":["4.3.1"],"package":"deepmerge","purl":"pkg:npm/deepmerge","source":"GHSA-gcqx-w48m-w2h4"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["3.15.0-2.1"],"introduced":["0"],"last_affected":[],"package":"golang-github-prometheus-prometheus","purl":"pkg:rpm/opensuse/golang-github-prometheus-prometheus\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2026:12285-1"}],"prev":{"headline":"CSSOM through 0.5.0 Denial of Service via length Property","id":"CVE-2026-93752"},"products":["deepmerge"],"published":"2026-09-18","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-09-24","vendors":["TehShrike"]},"summary":"Attackers can inject properties into object prototypes via merge operations, potentially leading to code execution or privilege escalation in applications using the library.","url":"https://insights.sbomify.com/CVE-2026-93753/"}