# CVE-2026-93853: Barman snapshot backup deletion trusts unverified backup catalog metadata

> An attacker with write access to the backup catalog can delete arbitrary cloud snapshots by manipulating metadata, requiring a split-identity deployment configuration.

- **Severity:** High 7.2 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:H/VA:H/SC:N/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Sep 2026
- **Updated:** 30 Sep 2026
- **Also known as:** DEBIAN-CVE-2026-93853, GHSA-hjpg-q85j-gwxx, UBUNTU-CVE-2026-93853

## What is CVE-2026-93853?

CVE-2026-93853 is a high-severity missing authorization vulnerability in EnterpriseDB Barman, published on 29 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Unverified ownership in Barman snapshot backup deletion allows a principal who can write the backup catalog to cause Barman to delete unrelated cloud snapshots. When a snapshot backup is deleted, either explicitly or by retention policy enforcement, Barman reads the snapshot identifiers from the backup.info file and passes them to the cloud provider's delete API using Barman's own credentials, without verifying that the snapshots belong to that backup. An attacker who can overwrite backup.info but lacks snapshot delete permissions can substitute the identifiers of other snapshots, causing Barman to delete any snapshot its cloud identity can reach on AWS, Microsoft Azure, or Google Cloud. Exploitation requires a deployment where the principal that writes the backup catalog is separate from the identity Barman uses to delete snapshots. Barman versions from 3.4.0 (Google Cloud), 3.6.0 (Azure), and 3.7.0 (AWS) up to and including 3.20.0 are affected. The issue is fixed in Barman 3.20.1.

Weakness: CWE-283 (Unverified Ownership)

## Which versions are affected by CVE-2026-93853?


## How do I fix CVE-2026-93853?

Upgrade to a fixed version.

## Is CVE-2026-93853 being exploited?

There is no known exploitation of CVE-2026-93853 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-93853 and fix it if it is affected.

What it is: CVE-2026-93853 is a high-severity missing authorization vulnerability in EnterpriseDB Barman, published on 29 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-93853 in the wild and no public exploit code.

Affected product: EnterpriseDB Barman. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-93853/ (Markdown: https://insights.sbomify.com/CVE-2026-93853/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-93853
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-93853
- OSV: https://osv.dev/vulnerability/CVE-2026-93853

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-93853/
Summaries are generated and may contain mistakes; the official description above is the record.
