# CVE-2026-93956: olivier-ls PHP-FTS Search SearchEngine.php buildHighlights cross site scripting

> Remote attackers can execute arbitrary scripts via the Query argument in the buildHighlights function of the PHP-FTS search library.

- **Severity:** Medium 5.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 19 Sep 2026
- **Updated:** 21 Sep 2026
- **Also known as:** GHSA-746c-pwvm-v4p5

## What is CVE-2026-93956?

CVE-2026-93956 is a medium-severity cross-site scripting vulnerability in olivier-ls PHP-FTS, published on 19 Sep 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

A flaw has been found in olivier-ls PHP-FTS up to 1.1.2. Affected by this issue is the function SearchEngine::buildHighlights of the file src/SearchEngine.php of the component Search Engine. Executing a manipulation of the argument Query can lead to cross site scripting. The attack may be launched remotely. The exploit has been published and may be used. Upgrading to version 1.1.3 can resolve this issue. This patch is called 0b2fae333d6b022da7ed4c43e2d41aa03f91dff3. The affected component should be upgraded. The vendor was contacted early, responded in a very professional manner and quickly released a fixed version of the affected product.

Weakness: CWE-94 (Improper Control of Generation of Code), CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-93956?


## How do I fix CVE-2026-93956?

No fix has been published for CVE-2026-93956 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-93956 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-93956 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-93956 and fix it if it is affected.

What it is: CVE-2026-93956 is a medium-severity cross-site scripting vulnerability in olivier-ls PHP-FTS, published on 19 Sep 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-93956 exists.

Affected product: olivier-ls PHP-FTS. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-93956/ (Markdown: https://insights.sbomify.com/CVE-2026-93956/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-93956
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-93956
- OSV: https://osv.dev/vulnerability/CVE-2026-93956

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-93956/
Summaries are generated and may contain mistakes; the official description above is the record.
