CVE-2026-93960 Pixelfed OAuth Scope ApiV1Controller.php instancePeers missing authentication

Medium 5.3 Published Updated

Remote attackers can access instance peer data without authentication due to missing checks in the API controller.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2026-93960?

CVE-2026-93960 is a medium-severity missing authorization vulnerability in Pixelfed, published on 20 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

A vulnerability was identified in Pixelfed up to 0.12.11. Impacted is the function instancePeers of the file app/Http/Controllers/Api/ApiV1Controller.php of the component OAuth Scope Handler. Such manipulation of the argument ID leads to missing authentication. The attack may be performed from remote. The exploit is publicly available and might be used. Upgrading to version 0.12.10 is recommended to address this issue. The name of the patch is 68dca5097305fa0065d029587b2233524636025a. Upgrading the affected component is advised.

Weakness: CWE-306, CWE-287

Which versions are affected by CVE-2026-93960?

How do I fix CVE-2026-93960?

No fix has been published for CVE-2026-93960 yet. Limit exposure of the affected software until one is available.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2026-93960 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-93960 exists.

Sources

Also known as GHSA-5jhw-m65c-75cw.

Is CVE-2026-93960 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free