# CVE-2026-93960: Pixelfed OAuth Scope ApiV1Controller.php instancePeers missing authentication

> Remote attackers can access instance peer data without authentication due to missing checks in the API controller.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 20 Sep 2026
- **Updated:** 22 Sep 2026
- **Also known as:** GHSA-5jhw-m65c-75cw

## What is CVE-2026-93960?

CVE-2026-93960 is a medium-severity missing authorization vulnerability in Pixelfed, published on 20 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A vulnerability was identified in Pixelfed up to 0.12.11. Impacted is the function instancePeers of the file app/Http/Controllers/Api/ApiV1Controller.php of the component OAuth Scope Handler. Such manipulation of the argument ID leads to missing authentication. The attack may be performed from remote. The exploit is publicly available and might be used. Upgrading to version 0.12.10 is recommended to address this issue. The name of the patch is 68dca5097305fa0065d029587b2233524636025a. Upgrading the affected component is advised.

Weakness: CWE-306 (Missing Authentication for Critical Functionality), CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2026-93960?


## How do I fix CVE-2026-93960?

No fix has been published for CVE-2026-93960 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-93960 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-93960 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-93960 and fix it if it is affected.

What it is: CVE-2026-93960 is a medium-severity missing authorization vulnerability in Pixelfed, published on 20 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-93960 exists.

Affected product: Pixelfed. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-93960/ (Markdown: https://insights.sbomify.com/CVE-2026-93960/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-93960
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-93960
- OSV: https://osv.dev/vulnerability/CVE-2026-93960

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-93960/
Summaries are generated and may contain mistakes; the official description above is the record.
