# CVE-2026-93986: rclone before 1.75.1 Path Traversal via Directory Listing Names

> Attackers can craft malicious directory names to attempt writing files outside the destination root, though local backend protections currently mitigate actual escape.

- **Severity:** Low 2.3 (`CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:P/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 19 Sep 2026
- **Updated:** 21 Sep 2026
- **Also known as:** BIT-rclone-2026-93986, DEBIAN-CVE-2026-93986, GHSA-3vxh-3pcx-9m8q, GHSA-9g4r-fhf6-vc4c, MINI-5qc3-vm4v-rf29, MINI-w23v-gqff-pj4g, UBUNTU-CVE-2026-93986

## What is CVE-2026-93986?

CVE-2026-93986 is a low-severity path traversal vulnerability in rclone, published on 19 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

rclone before 1.75.1 fails to confine names from server and third-party listing responses to the listed directory, allowing path traversal sequences in object names. Attackers can craft special names containing forward slashes and parent directory references to potentially write outside the destination root, though downstream protections in the local backend currently block actual file escape.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-93986?

1 open source package ship an affected version, including rclone.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `rclone` | Bitnami | All versions | 1.75.1 |

## How do I fix CVE-2026-93986?

Upgrade rclone to 1.75.1 or later.

## Is CVE-2026-93986 being exploited?

There is no known exploitation of CVE-2026-93986 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-93986 and fix it if it is affected.

What it is: CVE-2026-93986 is a low-severity path traversal vulnerability in rclone, published on 19 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-93986 in the wild and no public exploit code.

Affected packages and fixed versions:
- rclone (Bitnami): affected all versions; fixed in 1.75.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-93986/ (Markdown: https://insights.sbomify.com/CVE-2026-93986/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-93986
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-93986
- OSV: https://osv.dev/vulnerability/CVE-2026-93986

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-93986/
Summaries are generated and may contain mistakes; the official description above is the record.
