{"answers":{"affected":"1 open source package ship an affected version, including vllm. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-93989 in the wild and no public exploit code.","fix":"Upgrade vllm to 0.30.0 or later.","what":"CVE-2026-93989 is a low-severity memory corruption vulnerability in Vllm Vllm, published on 19 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-93989 and fix it if it is affected.\n\nWhat it is: CVE-2026-93989 is a low-severity memory corruption vulnerability in Vllm Vllm, published on 19 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-93989 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- vllm (PyPI): affected all versions; fixed in 0.30.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-93989/ (Markdown: https://insights.sbomify.com/CVE-2026-93989/index.md)","id":"CVE-2026-93989","markdown":"https://insights.sbomify.com/CVE-2026-93989/index.md","name":"CVE-2026-93989","record":{"aliases":["GHSA-pc5q-2x89-w436","MINI-hjj4-jr5g-8cmw","MINI-m2jx-j68h-jmxf","MINI-qchg-gg2q-q534","PYSEC-2026-4000"],"analysis":{"component_type":"library","fix_type":"patch","impacts":["data_read","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"LLM inference library","requires_auth":"low_privilege","summary":"Attackers can corrupt logits memory of concurrent requests by supplying out-of-bounds token indices, causing incorrect token generation.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[{"product":"vllm","vendor":"vllm"}],"cvss":{"score":2.3,"severity":"low","source":"cna","vector":"CVSS:4.0/AV:N/AC:H/AT:P/PR:L/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-129","name":"Improper Validation of Array Index"}],"description":"vLLM through 0.29.0 fails to properly validate bad_words token indices against the model's generation output width in SamplingParams.update_from_tokenizer(). Attackers can supply out-of-bounds token indices that corrupt logits memory of concurrent requests, causing different in-flight HTTP requests to return incorrect tokens.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"vLLM through 0.29.0 Cross-Request Logits Corruption via bad_words","id":"CVE-2026-93989","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":"vllm:vllm","products":["vllm:vllm"],"type":"memory_corruption","year":"2026"},"n_packages":1,"n_references":5,"next":{"headline":"Expat before 2.8.5 Malformed UTF-16 Acceptance via Unchecked Surrogate","id":"CVE-2026-93990"},"packages":[{"ecosystem":"PyPI","fixed":["0.30.0"],"introduced":["0"],"last_affected":[],"package":"vllm","purl":"pkg:pypi/vllm","source":"PYSEC-2026-4000"}],"prev":{"headline":"QloApps through 1.7.0 Arbitrary File Read via getEmailHTML","id":"CVE-2026-93988"},"products":["vllm"],"published":"2026-09-19","related":[{"cvss_score":10,"headline":"vLLM Vulnerable to Remote Code Execution via Mooncake Integration","id":"CVE-2025-32444","kev_date_added":null,"published":"2025-04-30"},{"cvss_score":9.8,"headline":"vLLM leaks a heap address when PIL throws an error","id":"CVE-2026-22778","kev_date_added":null,"published":"2026-02-02"},{"cvss_score":9.8,"headline":"vLLM Allows Remote Code Execution via PyNcclPipe Communication Service","id":"CVE-2025-47277","kev_date_added":null,"published":"2025-05-20"},{"cvss_score":9.8,"headline":"Remote Code Execution in vllm-project/vllm","id":"CVE-2024-11041","kev_date_added":null,"published":"2025-03-20"},{"cvss_score":9.1,"headline":"vLLM: OpenAI auth bypass","id":"CVE-2026-48746","kev_date_added":null,"published":"2026-06-22"},{"cvss_score":9.1,"headline":"vLLM Allows Remote Code Execution via Mooncake Integration","id":"CVE-2025-29783","kev_date_added":null,"published":"2025-03-19"},{"cvss_score":8.8,"headline":"vLLM 0.9.2 before 0.24.0 SSRF via X-Request-Id in P2pNcclConnector","id":"CVE-2026-116176","kev_date_added":null,"published":"2026-10-25"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-09-22","vendors":["vllm-project"]},"summary":"Attackers can corrupt logits memory of concurrent requests by supplying out-of-bounds token indices, causing incorrect token generation.","url":"https://insights.sbomify.com/CVE-2026-93989/"}