# CVE-2026-93989: vLLM through 0.29.0 Cross-Request Logits Corruption via bad_words

> Attackers can corrupt logits memory of concurrent requests by supplying out-of-bounds token indices, causing incorrect token generation.

- **Severity:** Low 2.3 (`CVSS:4.0/AV:N/AC:H/AT:P/PR:L/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Sep 2026
- **Updated:** 22 Sep 2026
- **Also known as:** GHSA-pc5q-2x89-w436, MINI-hjj4-jr5g-8cmw, MINI-m2jx-j68h-jmxf, MINI-qchg-gg2q-q534, PYSEC-2026-4000

## What is CVE-2026-93989?

CVE-2026-93989 is a low-severity memory corruption vulnerability in Vllm Vllm, published on 19 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

vLLM through 0.29.0 fails to properly validate bad_words token indices against the model's generation output width in SamplingParams.update_from_tokenizer(). Attackers can supply out-of-bounds token indices that corrupt logits memory of concurrent requests, causing different in-flight HTTP requests to return incorrect tokens.

Weakness: CWE-129 (Improper Validation of Array Index)

## Which versions are affected by CVE-2026-93989?

1 open source package ship an affected version, including vllm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vllm` | PyPI | All versions | 0.30.0 |

Products: Vllm Vllm.

## How do I fix CVE-2026-93989?

Upgrade vllm to 0.30.0 or later.

## Is CVE-2026-93989 being exploited?

There is no known exploitation of CVE-2026-93989 in the wild and no public exploit code.

## Other vulnerabilities in Vllm Vllm

- [CVE-2025-32444](https://insights.sbomify.com/CVE-2025-32444/): vLLM Vulnerable to Remote Code Execution via Mooncake Integration (critical 10.0)
- [CVE-2026-22778](https://insights.sbomify.com/CVE-2026-22778/): vLLM leaks a heap address when PIL throws an error (critical 9.8)
- [CVE-2025-47277](https://insights.sbomify.com/CVE-2025-47277/): vLLM Allows Remote Code Execution via PyNcclPipe Communication Service (critical 9.8)
- [CVE-2024-11041](https://insights.sbomify.com/CVE-2024-11041/): Remote Code Execution in vllm-project/vllm (critical 9.8)
- [CVE-2026-48746](https://insights.sbomify.com/CVE-2026-48746/): vLLM: OpenAI auth bypass (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-93989 and fix it if it is affected.

What it is: CVE-2026-93989 is a low-severity memory corruption vulnerability in Vllm Vllm, published on 19 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-93989 in the wild and no public exploit code.

Affected packages and fixed versions:
- vllm (PyPI): affected all versions; fixed in 0.30.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-93989/ (Markdown: https://insights.sbomify.com/CVE-2026-93989/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-93989
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-93989
- OSV: https://osv.dev/vulnerability/CVE-2026-93989

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-93989/
Summaries are generated and may contain mistakes; the official description above is the record.
