{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2026-93990 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2026-93990 is a high-severity vulnerability in libexpat, published on 19 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-93990 and fix it if it is affected.\n\nWhat it is: CVE-2026-93990 is a high-severity vulnerability in libexpat, published on 19 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-93990 in the wild and no public exploit code.\n\nAffected product: libexpat. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-93990/ (Markdown: https://insights.sbomify.com/CVE-2026-93990/index.md)","id":"CVE-2026-93990","markdown":"https://insights.sbomify.com/CVE-2026-93990/index.md","name":"CVE-2026-93990","record":{"aliases":["ALPINE-CVE-2026-93990","AZL-103316","AZL-105099","AZL-105149","AZL-105260","BELL-CVE-2026-93990","CLSA-2026-1790172968","CLSA-2026-1790177624","CLSA-2026-1790252195","CLSA-2026-1790252568","CLSA-2026-1790918446","CLSA-2026-1790919520","CLSA-2026-1790919725","DEBIAN-CVE-2026-93990","ECHO-41d9-8113-ce4d","GHSA-rfp9-ffqc-h4x8","OESA-2026-4175","OESA-2026-4176","OESA-2026-4177","OESA-2026-4178","RHSA-2026:71655","UBUNTU-CVE-2026-93990"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","other"],"network_reachable":"yes","non_default_config":false,"product_category":"XML parsing library","requires_auth":"none","summary":"Attackers can inject malformed UTF-16 sequences into XML, causing data corruption or silent character replacement in applications using the Expat library.","user_interaction":"not_required","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[],"cvss":{"score":8.7,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-176","name":"Improper Handling of Unicode Encoding"}],"description":"Expat before 2.8.5 fails to validate that a high surrogate in UTF-16 input is followed by a low surrogate, allowing malformed UTF-16 sequences to be accepted. Attackers can supply UTF-16 encoded XML containing lone high surrogates that consume the following code unit, causing Expat to pass unpaired surrogates to applications built with XML_UNICODE and to silently replace input characters in other builds.","ecosystems":["Red Hat:hummingbird:1"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Expat before 2.8.5 Malformed UTF-16 Acceptance via Unchecked Surrogate","id":"CVE-2026-93990","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"other","year":"2026"},"n_packages":3,"n_references":6,"next":{"headline":"Argo Workflows 4.1.0 through 4.1.3 Cross-Namespace Disclosure via Negated Selector","id":"CVE-2026-93991"},"packages":[{"ecosystem":"Red Hat:hummingbird:1","fixed":["0:2.8.4-0.2.hum1"],"introduced":["0"],"last_affected":[],"package":"expat","purl":"pkg:rpm/redhat/expat","source":"RHSA-2026:71655"},{"ecosystem":"Red Hat:hummingbird:1","fixed":["0:2.8.4-0.2.hum1"],"introduced":["0"],"last_affected":[],"package":"expat-devel","purl":"pkg:rpm/redhat/expat-devel","source":"RHSA-2026:71655"},{"ecosystem":"Red Hat:hummingbird:1","fixed":["0:2.8.4-0.2.hum1"],"introduced":["0"],"last_affected":[],"package":"expat-static","purl":"pkg:rpm/redhat/expat-static","source":"RHSA-2026:71655"}],"prev":{"headline":"vLLM through 0.29.0 Cross-Request Logits Corruption via bad_words","id":"CVE-2026-93989"},"products":["libexpat"],"published":"2026-09-19","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"Red Hat","prefix":"RHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-09-28","vendors":["libexpat"]},"summary":"Attackers can inject malformed UTF-16 sequences into XML, causing data corruption or silent character replacement in applications using the Expat library.","url":"https://insights.sbomify.com/CVE-2026-93990/"}