# CVE-2026-93991: Argo Workflows 4.1.0 through 4.1.3 Cross-Namespace Disclosure via Negated Selector

> Attackers with namespace list permissions can bypass authorization to read archived workflows from other namespaces, exposing sensitive parameters and annotations.

- **Severity:** High 8.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:H/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Sep 2026
- **Updated:** 21 Sep 2026
- **Also known as:** BIT-argo-workflows-2026-93991, GHSA-3fwg-9p8x-37mv, GHSA-q65w-j2vp-47c4, MINI-6hjf-wc65-6j94, MINI-gh54-75h2-5rmj, MINI-mjg7-h27f-vj5x, MINI-qf3j-34xf-cvc3

## What is CVE-2026-93991?

CVE-2026-93991 is a high-severity missing authorization vulnerability in argoproj argo-workflows, published on 19 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Argo Workflows versions 4.1.0 through 4.1.3 contain an authorization bypass vulnerability in ListArchivedWorkflows that fails to apply cluster-scoped access review when the metadata.namespace field selector uses the NotEquals operator. Attackers with namespace-scoped list permissions can use a negated namespace field selector to retrieve archived workflows from all other namespaces, exposing spec arguments, parameter values, and annotations.

Weakness: CWE-639 (Authorization Bypass Through User-Controlled Key)

## Which versions are affected by CVE-2026-93991?

1 open source package ship an affected version, including argo-workflows.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `argo-workflows` | Bitnami | From 4.1.0 | 4.1.4 |

## How do I fix CVE-2026-93991?

Upgrade argo-workflows to 4.1.4 or later.

## Is CVE-2026-93991 being exploited?

There is no known exploitation of CVE-2026-93991 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-93991 and fix it if it is affected.

What it is: CVE-2026-93991 is a high-severity missing authorization vulnerability in argoproj argo-workflows, published on 19 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-93991 in the wild and no public exploit code.

Affected packages and fixed versions:
- argo-workflows (Bitnami): affected from 4.1.0; fixed in 4.1.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-93991/ (Markdown: https://insights.sbomify.com/CVE-2026-93991/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-93991
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-93991
- OSV: https://osv.dev/vulnerability/CVE-2026-93991

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-93991/
Summaries are generated and may contain mistakes; the official description above is the record.
