# CVE-2026-93994: Apache MINA SSHD: Repeated-publickey policy bypass on server

> Attackers can bypass multi-factor public key authentication by presenting the same key twice in Apache MINA SSHD servers configured for repeated public key checks.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Sep 2026
- **Updated:** 30 Sep 2026
- **Also known as:** DEBIAN-CVE-2026-93994, GHSA-qc4p-9828-mv83, RHSA-2026:71541, UBUNTU-CVE-2026-93994

## What is CVE-2026-93994?

CVE-2026-93994 is a high-severity authentication bypass vulnerability in Apache MINA SSHD, published on 30 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Apache MINA SSHD is a Java library for client-side and server-side SSH. SSH servers can be configured to require multi-authentication schemes, for instance two different public keys, not just one. In OpenSSH, this would be done by setting in sshd_config AuthenticationMethods "publickey,publickey". Apache MINA SSHD provides an equivalent configuration mechanism.

In Apache MINA SSHD versions up to 2.19.0 and 3.0.0-M1 to 3.0.0-M5 the server code in component sshd-core does not enforce that the two public keys presented are different. A user can thus successfully authenticate with only one of the two key pairs required by presenting this single key twice. This is a partial authentication bypass.

Users are recommended to upgrade to version 2.20.0 or 3.0.0-M6, which fix this issue.

Weakness: CWE-304 (Missing Critical Step in Authentication)

## Which versions are affected by CVE-2026-93994?


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `maven3.9` | Red Hat:hummingbird:1 | All versions | 0:3.9.16-0.3.hum1 |
| `maven3.9-lib` | Red Hat:hummingbird:1 | All versions | 0:3.9.16-0.3.hum1 |

## How do I fix CVE-2026-93994?

Upgrade to a fixed version.

## Is CVE-2026-93994 being exploited?

There is no known exploitation of CVE-2026-93994 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-93994 and fix it if it is affected.

What it is: CVE-2026-93994 is a high-severity authentication bypass vulnerability in Apache MINA SSHD, published on 30 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-93994 in the wild and no public exploit code.

Affected product: Apache MINA SSHD. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-93994/ (Markdown: https://insights.sbomify.com/CVE-2026-93994/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-93994
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-93994
- OSV: https://osv.dev/vulnerability/CVE-2026-93994

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-93994/
Summaries are generated and may contain mistakes; the official description above is the record.
