CVE-2026-94212 Apache APISIX: unauthenticated impersonation issue in saml-auth
Unauthenticated attackers can impersonate any user on routes protected by the saml-auth plugin due to improper signature verification.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-94212?
CVE-2026-94212 is a medium-severity authentication bypass vulnerability in Apache APISIX, published on 1 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Improper verification of cryptographic signature vulnerability in Apache APISIX.
Any unauthenticated attacker could impersonate any user on every route protected by the saml-auth plugin under default configuration. This issue affects Apache APISIX: from 3.17.0 through 3.18.0.
Users are recommended to upgrade to version 3.19.0, which fixes the issue.
Weakness: CWE-347
Which versions are affected by CVE-2026-94212?
1 open source package ship an affected version, including apisix.
| Package | Affected | Fixed in |
|---|---|---|
apisix Bitnami | From 3.17.0 | 3.19.0 |
How do I fix CVE-2026-94212?
Upgrade apisix to 3.19.0 or later.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2026-94212 being exploited?
There is no known exploitation of CVE-2026-94212 in the wild and no public exploit code.
Sources
Also known as BIT-apisix-2026-94212, GHSA-9cp4-6jfv-7725, MINI-xpw9-5r5v-cjvw.