{"answers":{"affected":"1 open source package ship an affected version, including apisix.","exploited":"There is no known exploitation of CVE-2026-94212 in the wild and no public exploit code.","fix":"Upgrade apisix to 3.19.0 or later.","what":"CVE-2026-94212 is a medium-severity authentication bypass vulnerability in Apache APISIX, published on 1 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-94212 and fix it if it is affected.\n\nWhat it is: CVE-2026-94212 is a medium-severity authentication bypass vulnerability in Apache APISIX, published on 1 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-94212 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- apisix (Bitnami): affected from 3.17.0; fixed in 3.19.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-94212/ (Markdown: https://insights.sbomify.com/CVE-2026-94212/index.md)","id":"CVE-2026-94212","markdown":"https://insights.sbomify.com/CVE-2026-94212/index.md","name":"CVE-2026-94212","record":{"aliases":["BIT-apisix-2026-94212","GHSA-9cp4-6jfv-7725","MINI-xpw9-5r5v-cjvw"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["account_takeover","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"API Gateway","requires_auth":"low_privilege","summary":"Unauthenticated attackers can impersonate any user on routes protected by the saml-auth plugin due to improper signature verification.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[],"cvss":{"score":6.4,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:N","version":"4.0"},"cwes":[{"id":"CWE-347","name":"Improper Verification of Cryptographic Signature"}],"description":"Improper verification of cryptographic signature vulnerability in Apache APISIX.\n\nAny unauthenticated attacker could impersonate any user on every route protected by the saml-auth plugin under default configuration. This issue affects Apache APISIX: from 3.17.0 through 3.18.0.\n\nUsers are recommended to upgrade to version 3.19.0, which fixes the issue.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache APISIX: unauthenticated impersonation issue in saml-auth","id":"CVE-2026-94212","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"auth_bypass","year":"2026"},"n_packages":1,"n_references":1,"next":{"headline":"Keycloak-services: keycloak-services: authorization services policy evaluation endpoint leaks user identity","id":"CVE-2026-94213"},"packages":[{"ecosystem":"Bitnami","fixed":["3.19.0"],"introduced":["3.17.0"],"last_affected":[],"package":"apisix","purl":"pkg:bitnami/apisix","source":"BIT-apisix-2026-94212"}],"prev":{"headline":"Hyve5 Leantime Project Dashboard show.blade.php cross site scripting","id":"CVE-2026-94211"},"products":["Apache APISIX"],"published":"2026-10-01","related":[],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-10-01","vendors":["Apache Software Foundation"]},"summary":"Unauthenticated attackers can impersonate any user on routes protected by the saml-auth plugin due to improper signature verification.","url":"https://insights.sbomify.com/CVE-2026-94212/"}