CVE-2026-94220 Apache APISIX: session fixation issue in feishu-auth and dingtalk-auth plugin
Attackers can hijack user sessions via CSRF in APISIX auth plugins, causing user actions to execute under the attacker's account.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2026-94220?
CVE-2026-94220 is a low-severity vulnerability in Apache APISIX, published on 1 Oct 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Cross-Site request forgery (CSRF) vulnerability in feishu-auth and dingtalk-auth plugins in Apache APISIX.
An attacker who can get a user to click a crafted link may cause that user's browser session on a protected route to be established under the attacker's identity instead of their own. Any work the user then performs in that session, including uploads, form submissions, and account bindings, lands in the attacker's account. This issue affects Apache APISIX: from 3.17.0 through 3.18.0.
Users are recommended to upgrade to version 3.19.0, which fixes the issue.
Weakness: CWE-352
Which versions are affected by CVE-2026-94220?
1 open source package ship an affected version, including apisix.
| Package | Affected | Fixed in |
|---|---|---|
apisix Bitnami | From 3.17.0 | 3.19.0 |
How do I fix CVE-2026-94220?
Upgrade apisix to 3.19.0 or later.
Is CVE-2026-94220 being exploited?
There is no known exploitation of CVE-2026-94220 in the wild and no public exploit code.
Sources
Also known as BIT-apisix-2026-94220, GHSA-6627-r6cp-53w5, MINI-24gq-xm2q-r3m4.