{"answers":{"affected":"1 open source package ship an affected version, including apisix.","exploited":"There is no known exploitation of CVE-2026-94220 in the wild and no public exploit code.","fix":"Upgrade apisix to 3.19.0 or later.","what":"CVE-2026-94220 is a low-severity vulnerability in Apache APISIX, published on 1 Oct 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-94220 and fix it if it is affected.\n\nWhat it is: CVE-2026-94220 is a low-severity vulnerability in Apache APISIX, published on 1 Oct 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-94220 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- apisix (Bitnami): affected from 3.17.0; fixed in 3.19.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-94220/ (Markdown: https://insights.sbomify.com/CVE-2026-94220/index.md)","id":"CVE-2026-94220","markdown":"https://insights.sbomify.com/CVE-2026-94220/index.md","name":"CVE-2026-94220","record":{"aliases":["BIT-apisix-2026-94220","GHSA-6627-r6cp-53w5","MINI-24gq-xm2q-r3m4"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["account_takeover","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"API Gateway","requires_auth":"none","summary":"Attackers can hijack user sessions via CSRF in APISIX auth plugins, causing user actions to execute under the attacker's account.","user_interaction":"required","vuln_class":"csrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[],"cvss":{"score":2.1,"severity":"low","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N","version":"4.0"},"cwes":[{"id":"CWE-352","name":"Cross-Site Request Forgery"}],"description":"Cross-Site request forgery (CSRF) vulnerability in feishu-auth and dingtalk-auth plugins in Apache APISIX.\n\nAn attacker who can get a user to click a crafted link may cause that user's browser session on a protected route to be established under the attacker's identity instead of their own. Any work the user then performs in that session, including uploads, form submissions, and account bindings, lands in the attacker's account. This issue affects Apache APISIX: from 3.17.0 through 3.18.0.\n\nUsers are recommended to upgrade to version 3.19.0, which fixes the issue.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache APISIX: session fixation issue in feishu-auth and dingtalk-auth plugin","id":"CVE-2026-94220","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"csrf","year":"2026"},"n_packages":1,"n_references":1,"next":{"headline":"TrueBooker Appointment Booking 1.1.9 - 1.2.9 - Unauthenticated Plugin Settings Overwrite via admin_setting_setup_data","id":"CVE-2026-94228"},"packages":[{"ecosystem":"Bitnami","fixed":["3.19.0"],"introduced":["3.17.0"],"last_affected":[],"package":"apisix","purl":"pkg:bitnami/apisix","source":"BIT-apisix-2026-94220"}],"prev":{"headline":"Keycloak-services: keycloak-services: 2fa setup enforcement bypass via authentication session restart endpoint","id":"CVE-2026-94218"},"products":["Apache APISIX"],"published":"2026-10-01","related":[],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-10-01","vendors":["Apache Software Foundation"]},"summary":"Attackers can hijack user sessions via CSRF in APISIX auth plugins, causing user actions to execute under the attacker's account.","url":"https://insights.sbomify.com/CVE-2026-94220/"}