# CVE-2026-94220: Apache APISIX: session fixation issue in feishu-auth and dingtalk-auth plugin

> Attackers can hijack user sessions via CSRF in APISIX auth plugins, causing user actions to execute under the attacker's account.

- **Severity:** Low 2.1 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 1 Oct 2026
- **Updated:** 1 Oct 2026
- **Also known as:** BIT-apisix-2026-94220, GHSA-6627-r6cp-53w5, MINI-24gq-xm2q-r3m4

## What is CVE-2026-94220?

CVE-2026-94220 is a low-severity vulnerability in Apache APISIX, published on 1 Oct 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Cross-Site request forgery (CSRF) vulnerability in feishu-auth and dingtalk-auth plugins in Apache APISIX.

An attacker who can get a user to click a crafted link may cause that user's browser session on a protected route to be established under the attacker's identity instead of their own. Any work the user then performs in that session, including uploads, form submissions, and account bindings, lands in the attacker's account. This issue affects Apache APISIX: from 3.17.0 through 3.18.0.

Users are recommended to upgrade to version 3.19.0, which fixes the issue.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2026-94220?

1 open source package ship an affected version, including apisix.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apisix` | Bitnami | From 3.17.0 | 3.19.0 |

## How do I fix CVE-2026-94220?

Upgrade apisix to 3.19.0 or later.

## Is CVE-2026-94220 being exploited?

There is no known exploitation of CVE-2026-94220 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-94220 and fix it if it is affected.

What it is: CVE-2026-94220 is a low-severity vulnerability in Apache APISIX, published on 1 Oct 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-94220 in the wild and no public exploit code.

Affected packages and fixed versions:
- apisix (Bitnami): affected from 3.17.0; fixed in 3.19.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-94220/ (Markdown: https://insights.sbomify.com/CVE-2026-94220/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-94220
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-94220
- OSV: https://osv.dev/vulnerability/CVE-2026-94220

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-94220/
Summaries are generated and may contain mistakes; the official description above is the record.
