CVE-2026-94250 Apache APISIX: Batch response aggregation can exhaust worker memory
Unauthenticated attackers can cause denial of service by exhausting worker memory via the batch-requests plugin in Apache APISIX.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-94250?
CVE-2026-94250 is a high-severity denial of service vulnerability in Apache APISIX, published on 1 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Allocation of resources without limits or throttling vulnerability in batch-requests plugin in Apache APISIX.
An unauthenticated caller can drive a gateway worker into OOM via a route where the batch-requests plugin is used and the batch endpoint is publicly exposed. This issue affects Apache APISIX: from 1.3.0 through 3.18.0.
Users are recommended to upgrade to version 3.19.0, which fixes the issue.
Weakness: CWE-770
Which versions are affected by CVE-2026-94250?
1 open source package ship an affected version, including apisix.
| Package | Affected | Fixed in |
|---|---|---|
apisix Bitnami | From 1.3.0 | 3.19.0 |
How do I fix CVE-2026-94250?
Upgrade apisix to 3.19.0 or later.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-94250 being exploited?
There is no known exploitation of CVE-2026-94250 in the wild and no public exploit code.
Sources
Also known as BIT-apisix-2026-94250, GHSA-2qwv-5jcq-cgff, MINI-vm6f-27p8-cjpj.