{"answers":{"affected":"1 open source package ship an affected version, including apisix.","exploited":"There is no known exploitation of CVE-2026-94269 in the wild and no public exploit code.","fix":"Upgrade apisix to 3.19.0 or later.","what":"CVE-2026-94269 is a medium-severity authentication bypass vulnerability in Apache APISIX, published on 1 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-94269 and fix it if it is affected.\n\nWhat it is: CVE-2026-94269 is a medium-severity authentication bypass vulnerability in Apache APISIX, published on 1 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-94269 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- apisix (Bitnami): affected from 2.14.1; fixed in 3.19.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-94269/ (Markdown: https://insights.sbomify.com/CVE-2026-94269/index.md)","id":"CVE-2026-94269","markdown":"https://insights.sbomify.com/CVE-2026-94269/index.md","name":"CVE-2026-94269","record":{"aliases":["BIT-apisix-2026-94269","GHSA-37wm-6fqc-r75p","MINI-55v2-p3f6-vxg4"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["security_bypass","data_read"],"network_reachable":"yes","non_default_config":true,"product_category":"API Gateway","requires_auth":"none","summary":"Attackers can bypass authorization checks via crafted URL paths to access protected upstream endpoints in Apache APISIX.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[],"cvss":{"score":6.3,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N","version":"4.0"},"cwes":[{"id":"CWE-647","name":"Use of Non-Canonical URL Paths for Authorization Decisions"}],"description":"Use of Non-Canonical URL paths for authorization decisions vulnerability in Apache APISIX.\n\nIn some configurations where a permissive route overlaps a protected one, a crafted encoded path can reach an upstream endpoint that the matched route's policies were never meant to cover. A request that should have been rejected is served instead, giving unauthenticated access to a protected upstream endpoint. This issue affects Apache APISIX: from 2.14.1 through 3.18.0.\n\nUsers are recommended to upgrade to version 3.19.0, which fixes the issue.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache APISIX: Servlet-style normalization creates a route/upstream authorization mismatch","id":"CVE-2026-94269","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"auth_bypass","year":"2026"},"n_packages":1,"n_references":1,"next":{"headline":"Deema Payment Gateway \u003c= 1.1.2 - Unauthenticated Payment Bypass and Order Manipulation via Webhook","id":"CVE-2026-94270"},"packages":[{"ecosystem":"Bitnami","fixed":["3.19.0"],"introduced":["2.14.1"],"last_affected":[],"package":"apisix","purl":"pkg:bitnami/apisix","source":"BIT-apisix-2026-94269"}],"prev":{"headline":"The Advanced Custom Fields: Extended WordPress plugin before 0.9.2.8, Advanced Custom Fields: Extended PRO WordPress plugin before 0.9.2.8 d","id":"CVE-2026-94268"},"products":["Apache APISIX"],"published":"2026-10-01","related":[],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-10-01","vendors":["Apache Software Foundation"]},"summary":"Attackers can bypass authorization checks via crafted URL paths to access protected upstream endpoints in Apache APISIX.","url":"https://insights.sbomify.com/CVE-2026-94269/"}