# CVE-2026-94269: Apache APISIX: Servlet-style normalization creates a route/upstream authorization mismatch

> Attackers can bypass authorization checks via crafted URL paths to access protected upstream endpoints in Apache APISIX.

- **Severity:** Medium 6.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Oct 2026
- **Updated:** 1 Oct 2026
- **Also known as:** BIT-apisix-2026-94269, GHSA-37wm-6fqc-r75p, MINI-55v2-p3f6-vxg4

## What is CVE-2026-94269?

CVE-2026-94269 is a medium-severity authentication bypass vulnerability in Apache APISIX, published on 1 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Use of Non-Canonical URL paths for authorization decisions vulnerability in Apache APISIX.

In some configurations where a permissive route overlaps a protected one, a crafted encoded path can reach an upstream endpoint that the matched route's policies were never meant to cover. A request that should have been rejected is served instead, giving unauthenticated access to a protected upstream endpoint. This issue affects Apache APISIX: from 2.14.1 through 3.18.0.

Users are recommended to upgrade to version 3.19.0, which fixes the issue.

Weakness: CWE-647 (Use of Non-Canonical URL Paths for Authorization Decisions)

## Which versions are affected by CVE-2026-94269?

1 open source package ship an affected version, including apisix.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apisix` | Bitnami | From 2.14.1 | 3.19.0 |

## How do I fix CVE-2026-94269?

Upgrade apisix to 3.19.0 or later.

## Is CVE-2026-94269 being exploited?

There is no known exploitation of CVE-2026-94269 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-94269 and fix it if it is affected.

What it is: CVE-2026-94269 is a medium-severity authentication bypass vulnerability in Apache APISIX, published on 1 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-94269 in the wild and no public exploit code.

Affected packages and fixed versions:
- apisix (Bitnami): affected from 2.14.1; fixed in 3.19.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-94269/ (Markdown: https://insights.sbomify.com/CVE-2026-94269/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-94269
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-94269
- OSV: https://osv.dev/vulnerability/CVE-2026-94269

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-94269/
Summaries are generated and may contain mistakes; the official description above is the record.
