CVE-2026-94276 Apache APISIX: Openid-connect introspection validation issue
Attackers can bypass authentication on routes restricted to specific issuers by using tokens valid for other issuers in multi-issuer setups.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-94276?
CVE-2026-94276 is a medium-severity authentication bypass vulnerability in Apache APISIX, published on 1 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Improper Authentication vulnerability in Apache APISIX.
On a route using openid-connect plugin with remote introspection against an authorization server that serves multiple issuers, a token that introspects as active for one issuer may get accepted on a route restricted to another. This issue affects Apache APISIX: from 3.12.0 through 3.18.0.
Users are recommended to upgrade to version 3.19.0, which fixes the issue.
Weakness: CWE-287
Which versions are affected by CVE-2026-94276?
1 open source package ship an affected version, including apisix.
| Package | Affected | Fixed in |
|---|---|---|
apisix Bitnami | From 3.12.0 | 3.19.0 |
How do I fix CVE-2026-94276?
Upgrade apisix to 3.19.0 or later.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2026-94276 being exploited?
There is no known exploitation of CVE-2026-94276 in the wild and no public exploit code.
Sources
Also known as BIT-apisix-2026-94276, GHSA-9v5j-4cf2-q593, MINI-j7c9-vpfp-mw9g.