# CVE-2026-94276: Apache APISIX: Openid-connect introspection validation issue

> Attackers can bypass authentication on routes restricted to specific issuers by using tokens valid for other issuers in multi-issuer setups.

- **Severity:** Medium 5.1 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:N/VA:N/SC:H/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Oct 2026
- **Updated:** 1 Oct 2026
- **Also known as:** BIT-apisix-2026-94276, GHSA-9v5j-4cf2-q593, MINI-j7c9-vpfp-mw9g

## What is CVE-2026-94276?

CVE-2026-94276 is a medium-severity authentication bypass vulnerability in Apache APISIX, published on 1 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Improper Authentication vulnerability in Apache APISIX.

On a route using openid-connect plugin with remote introspection against an authorization server that serves multiple issuers, a token that introspects as active for one issuer may get accepted on a route restricted to another. This issue affects Apache APISIX: from 3.12.0 through 3.18.0.

Users are recommended to upgrade to version 3.19.0, which fixes the issue.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2026-94276?

1 open source package ship an affected version, including apisix.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apisix` | Bitnami | From 3.12.0 | 3.19.0 |

## How do I fix CVE-2026-94276?

Upgrade apisix to 3.19.0 or later.

## Is CVE-2026-94276 being exploited?

There is no known exploitation of CVE-2026-94276 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-94276 and fix it if it is affected.

What it is: CVE-2026-94276 is a medium-severity authentication bypass vulnerability in Apache APISIX, published on 1 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-94276 in the wild and no public exploit code.

Affected packages and fixed versions:
- apisix (Bitnami): affected from 3.12.0; fixed in 3.19.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-94276/ (Markdown: https://insights.sbomify.com/CVE-2026-94276/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-94276
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-94276
- OSV: https://osv.dev/vulnerability/CVE-2026-94276

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-94276/
Summaries are generated and may contain mistakes; the official description above is the record.
