{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2026-94287 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2026-94287 is a medium-severity vulnerability in x.org libXpm, published on 28 Sep 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-94287 and fix it if it is affected.\n\nWhat it is: CVE-2026-94287 is a medium-severity vulnerability in x.org libXpm, published on 28 Sep 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-94287 in the wild and no public exploit code.\n\nAffected product: x.org libXpm. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-94287/ (Markdown: https://insights.sbomify.com/CVE-2026-94287/index.md)","id":"CVE-2026-94287","markdown":"https://insights.sbomify.com/CVE-2026-94287/index.md","name":"CVE-2026-94287","record":{"aliases":["ALPINE-CVE-2026-94287","BELL-CVE-2026-94287","DEBIAN-CVE-2026-94287","ECHO-35bc-714c-9ad7","GHSA-ggh5-2m6x-59xg","MGASA-2026-0527","OESA-2026-4292","OESA-2026-4293","OESA-2026-4294","OESA-2026-4295","SUSE-SU-2026:24204-1","SUSE-SU-2026:4761-1","SUSE-SU-2026:4763-1","UBUNTU-CVE-2026-94287","USN-8862-1","openSUSE-SU-2026:11896-1","openSUSE-SU-2026:22056-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"X11 image library","requires_auth":"none","summary":"Local attackers can cause denial of service via unbounded CPU and memory usage due to an unsigned underflow in libXpm's write path.","user_interaction":"required","vuln_class":"integer_overflow"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"suse","cpe":[],"cvss":{"score":5.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-1050","name":"Excessive Platform Resource Consumption within a Loop"}],"description":"A denial of service via unsigned underflow in libXpm's write path in libXpm before 3.5.19 could be used by local attackers to cause unbounded CPU usage and memory exhaustion.","ecosystems":["SUSE:Linux Enterprise Module for Basesystem 15 SP7","SUSE:Linux Enterprise Module for Package Hub 15 SP7","SUSE:Linux Enterprise Server 16.0","SUSE:Linux Enterprise Server LTSS Extended Security 12 SP5","SUSE:Linux Enterprise Server for SAP applications 16.0","SUSE:Linux Enterprise Workstation Extension 15 SP7","openSUSE:Leap 16.0","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Denial of service via unsigned underflow in libXpm's write path","id":"CVE-2026-94287","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"integer_overflow","year":"2026"},"n_packages":8,"n_references":1,"next":{"headline":"Missing authentication for critical function in the aas-edge-client REST API","id":"CVE-2026-94293"},"packages":[{"ecosystem":"SUSE:Linux Enterprise Module for Basesystem 15 SP7","fixed":["3.5.12-150000.3.13.1"],"introduced":["0"],"last_affected":[],"package":"libXpm","purl":"pkg:rpm/suse/libXpm\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Basesystem%2015%20SP7","source":"SUSE-SU-2026:4763-1"},{"ecosystem":"SUSE:Linux Enterprise Module for Package Hub 15 SP7","fixed":["3.5.12-150000.3.13.1"],"introduced":["0"],"last_affected":[],"package":"libXpm","purl":"pkg:rpm/suse/libXpm\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Package%20Hub%2015%20SP7","source":"SUSE-SU-2026:4763-1"},{"ecosystem":"SUSE:Linux Enterprise Server 16.0","fixed":["3.5.17-160000.4.1"],"introduced":["0"],"last_affected":[],"package":"libXpm","purl":"pkg:rpm/suse/libXpm\u0026distro=SUSE%20Linux%20Enterprise%20Server%2016.0","source":"SUSE-SU-2026:24204-1"},{"ecosystem":"SUSE:Linux Enterprise Server LTSS Extended Security 12 SP5","fixed":["3.5.11-6.13.1"],"introduced":["0"],"last_affected":[],"package":"libXpm","purl":"pkg:rpm/suse/libXpm\u0026distro=SUSE%20Linux%20Enterprise%20Server%20LTSS%20Extended%20Security%2012%20SP5","source":"SUSE-SU-2026:4761-1"},{"ecosystem":"SUSE:Linux Enterprise Server for SAP applications 16.0","fixed":["3.5.17-160000.4.1"],"introduced":["0"],"last_affected":[],"package":"libXpm","purl":"pkg:rpm/suse/libXpm\u0026distro=SUSE%20Linux%20Enterprise%20Server%20for%20SAP%20applications%2016.0","source":"SUSE-SU-2026:24204-1"},{"ecosystem":"SUSE:Linux Enterprise Workstation Extension 15 SP7","fixed":["3.5.12-150000.3.13.1"],"introduced":["0"],"last_affected":[],"package":"libXpm","purl":"pkg:rpm/suse/libXpm\u0026distro=SUSE%20Linux%20Enterprise%20Workstation%20Extension%2015%20SP7","source":"SUSE-SU-2026:4763-1"},{"ecosystem":"openSUSE:Leap 16.0","fixed":["3.5.17-160000.4.1"],"introduced":["0"],"last_affected":[],"package":"libXpm","purl":"pkg:rpm/opensuse/libXpm\u0026distro=openSUSE%20Leap%2016.0","source":"openSUSE-SU-2026:22056-1"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["3.5.18-3.1"],"introduced":["0"],"last_affected":[],"package":"libXpm","purl":"pkg:rpm/opensuse/libXpm\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2026:11896-1"}],"prev":{"headline":"Out-of-bounds read in libXtst's RECORD reply parser","id":"CVE-2026-94286"},"products":["libXpm"],"published":"2026-09-28","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-09-28","vendors":["x.org"]},"summary":"Local attackers can cause denial of service via unbounded CPU and memory usage due to an unsigned underflow in libXpm's write path.","url":"https://insights.sbomify.com/CVE-2026-94287/"}