# CVE-2026-94450: Potential denial of service when configured to send Retry packets in s2n-quic

> An unauthenticated remote attacker can cause a denial of service in s2n-quic servers configured to send Retry packets by sending a crafted UDP datagram.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 22 Sep 2026
- **Updated:** 20 Oct 2026
- **Also known as:** GHSA-5rw2-6x5m-v22x

## What is CVE-2026-94450?

CVE-2026-94450 is a high-severity denial of service vulnerability in AWS s2n-quic, published on 22 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Improper validation of the Destination Connection ID length in s2n-quic 1.88.0 and earlier may allow an unauthenticated remote user to cause a denial of service by shutting down a server endpoint via a single crafted UDP datagram. Only server endpoints specifically configured to send Retry packets are affected.

To remediate this issue, users should upgrade to version v1.89.0 or later.

Weakness: CWE-617 (Reachable Assertion), CWE-1284 (Improper Validation of Specified Quantity in Input)

## Which versions are affected by CVE-2026-94450?


## How do I fix CVE-2026-94450?

No fix has been published for CVE-2026-94450 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-94450 being exploited?

There is no known exploitation of CVE-2026-94450 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-94450 and fix it if it is affected.

What it is: CVE-2026-94450 is a high-severity denial of service vulnerability in AWS s2n-quic, published on 22 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-94450 in the wild and no public exploit code.

Affected product: AWS s2n-quic. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-94450/ (Markdown: https://insights.sbomify.com/CVE-2026-94450/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-94450
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-94450
- OSV: https://osv.dev/vulnerability/CVE-2026-94450

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-94450/
Summaries are generated and may contain mistakes; the official description above is the record.
