# CVE-2026-94544: Next.js: Pending `use cache` fill can leak Draft Mode content into regular responses and persisted pages

> Attackers can access unpublished draft content or serve stale published content due to shared cache keys in Next.js when cache components are enabled.

- **Severity:** Medium 6.3 (`CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Oct 2026
- **Updated:** 5 Oct 2026
- **Also known as:** CLEANSTART-2026-LU91750, CLEANSTART-2026-VM40909, CLEANSTART-2026-WK31572, CLEANSTART-2026-ZM21306, GHSA-3w37-wq28-93x7, MINI-55j4-j67m-cch7, MINI-65h7-9cch-qrph, MINI-h5gf-vxrp-jvx8

## What is CVE-2026-94544?

CVE-2026-94544 is a medium-severity vulnerability in Vercel Next.js, published on 2 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Next.js is a React framework for building full-stack web applications. From 16.3.0 until 16.3.8, pending use cache fills for the same key are shared without separating Draft Mode requests from regular requests. An overlapping regular request can receive unauthenticated unpublished content from an editor's Draft Mode fill, while an overlapping Draft Mode request can receive published content from a regular fill. When the regular request prerenders a page, the draft-dependent content can persist in the generated page and be served to later visitors until revalidation. Sites are affected when Cache Components or experimental.useCache is enabled and cached functions return draft-dependent content. This issue is fixed in version 16.3.8.

Weakness: CWE-524 (Use of Cache Containing Sensitive Information)

## Which versions are affected by CVE-2026-94544?

2 open source packages ship an affected version, including next. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `next` | npm | From 16.3.0 | 16.3.8 |
| `next` | npm | From 16.3.0 | 16.3.8 |

Products: Vercel Next.js.

## How do I fix CVE-2026-94544?

Upgrade next to 16.3.8 or later.

## Is CVE-2026-94544 being exploited?

There is no known exploitation of CVE-2026-94544 in the wild and no public exploit code.

## Other vulnerabilities in Vercel Next.js

- [CVE-2025-29927](https://insights.sbomify.com/CVE-2025-29927/): Authorization Bypass in Next.js Middleware (critical 9.1)
- [CVE-2026-44578](https://insights.sbomify.com/CVE-2026-44578/): Next.js: Server-side request forgery in applications using WebSocket upgrades (high 8.6)
- [CVE-2026-94483](https://insights.sbomify.com/CVE-2026-94483/): Next.js: Server-Side Request Forgery in Image Optimization (high 8.3)
- [CVE-2026-64642](https://insights.sbomify.com/CVE-2026-64642/): Next.js: Middleware / Proxy bypass in App Router applications using Turbopack and single locale (high 8.3)
- [CVE-2026-64645](https://insights.sbomify.com/CVE-2026-64645/): Next.js: Server-Side Request Forgery in rewrites via attacker-controlled destination hostname (high 8.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-94544 and fix it if it is affected.

What it is: CVE-2026-94544 is a medium-severity vulnerability in Vercel Next.js, published on 2 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-94544 in the wild and no public exploit code.

Affected packages and fixed versions:
- next (npm): affected from 16.3.0; fixed in 16.3.8
- next (npm): affected from 16.3.0; fixed in 16.3.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-94544/ (Markdown: https://insights.sbomify.com/CVE-2026-94544/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-94544
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-94544
- OSV: https://osv.dev/vulnerability/CVE-2026-94544

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-94544/
Summaries are generated and may contain mistakes; the official description above is the record.
