{"answers":{"affected":"2 open source packages ship an affected version, including satori.","exploited":"There is no known exploitation of CVE-2026-94545 in the wild and no public exploit code.","fix":"Upgrade satori to 0.33.5 or later.","what":"CVE-2026-94545 is a medium-severity cross-site scripting vulnerability in vercel next, published on 30 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-94545 and fix it if it is affected.\n\nWhat it is: CVE-2026-94545 is a medium-severity cross-site scripting vulnerability in vercel next, published on 30 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-94545 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- satori (npm): affected from 0.0.27; fixed in 0.33.5\n- satori (npm): affected from 0.0.27; fixed in 0.33.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-94545/ (Markdown: https://insights.sbomify.com/CVE-2026-94545/index.md)","id":"CVE-2026-94545","markdown":"https://insights.sbomify.com/CVE-2026-94545/index.md","name":"CVE-2026-94545","record":{"aliases":["GHSA-wx4j-mvgx-mqwp"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"HTML to SVG library","requires_auth":"none","summary":"Attackers can inject malicious SVG markup via improper escaping in Satori, potentially leading to code execution when rendered.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:N/VI:N/VA:N/SC:H/SI:H/SA:N","version":"4.0"},"cwes":[{"id":"CWE-116","name":"Improper Encoding or Escaping of Output"}],"description":"Satori is a library to convert HTML and CSS to SVG. Starting in version 0.0.27 and prior to version 0.33.5, Satori does not properly escape certain values before including them in generated SVG output. This can allow crafted values to be interpreted as SVG markup. The impact depends on how the generated SVG is consumed. Version 0.33.5 contains a patch. No complete workaround exists besides upgrading. Applications that cannot immediately upgrade should not render attacker-controlled content with Satori.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":"2026-09-23","github_poc":4,"max_poc_stars":52,"metasploit":0,"nuclei":0,"refs":[{"date":"2026-09-29T07:57:18Z","kind":"github_poc","ref":"https://github.com/EQSTLab/CVE-2026-94545","stars":52,"title":"Next.js RCE"},{"date":"2026-09-23T07:13:04Z","kind":"github_poc","ref":"https://github.com/HORKimhab/CVE-2026-94545","stars":1,"title":"CVE-2026-94545 - Draft or TODO"},{"date":"2026-09-23T14:51:59Z","kind":"github_poc","ref":"https://github.com/Hassham1/CVE-2026-94545-nextjs-og-poc","stars":1,"title":"CVE-2026-94545 / GHSA-vcvr-r3jv-pc5j — Next.js next/og ImageResponse SVG injection (Satori, GHSA-wx4j-mvgx-mqwp): isolated Docker validation lab with vulnerable (16.3.5) vs patched (16.3.6) controls, non-destructive Python scanner with pixel-level PNG evidence, and root-cause analysis of the upstream Satori fix. Authorized security research only."},{"date":"2026-09-30T15:12:57Z","kind":"github_poc","ref":"https://github.com/MRdark-ops/CVE-2026-94545-","stars":1,"title":"Next.js next/og unauthenticated RCE (CVE-2026-94545) - PoC"}],"tier":"poc_unverified"},"has_fix":true,"headline":"Satori-generated SVG has improper escaping","id":"CVE-2026-94545","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2026"},"n_packages":2,"n_references":6,"next":{"headline":"WordPress Pay with Vipps for WooCommerce plugin \u003c= 6.2.0 - PHP Object Injection vulnerability","id":"CVE-2026-94568"},"packages":[{"ecosystem":"npm","fixed":["0.33.5"],"introduced":["0.0.27"],"last_affected":[],"package":"satori","purl":null,"source":"GHSA-wx4j-mvgx-mqwp"},{"ecosystem":"npm","fixed":["0.33.5"],"introduced":["0.0.27"],"last_affected":[],"package":"satori","purl":"pkg:npm/satori","source":"GHSA-wx4j-mvgx-mqwp"}],"prev":{"headline":"Next.js: Pending `use cache` fill can leak Draft Mode content into regular responses and persisted pages","id":"CVE-2026-94544"},"products":["next","satori"],"published":"2026-09-30","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-09-30","vendors":["vercel"]},"summary":"Attackers can inject malicious SVG markup via improper escaping in Satori, potentially leading to code execution when rendered.","url":"https://insights.sbomify.com/CVE-2026-94545/"}