CVE-2026-94603 Podman: The `podman run` command can be instructed to disable almost all sandboxing by image annotation
Attackers can bypass container sandboxing restrictions via image annotations, potentially escalating privileges within the host environment.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-94603?
CVE-2026-94603 is a critical vulnerability in podman-container-tools podman, published on 13 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Podman is a tool for managing OCI containers and pods. From 4.4.0 until 5.8.8 and 6.1.3, podman run treats an image carrying the io.podman.annotations.checkpoint.runtime.name annotation as a checkpoint and silently ignores user-supplied container creation restrictions such as --cap-drop=ALL, allowing image-controlled checkpoint state to select weaker sandbox settings and capabilities. Rootless containers are not affected because checkpoint and restore are unavailable in that mode. This issue is fixed in versions 5.8.8 and 6.1.3.
Weakness: CWE-693
Which versions are affected by CVE-2026-94603?
10 open source packages ship an affected version, including github.com/containers/podman, github.com/containers/podman/v2 and github.com/containers/podman/v3.
| Package | Affected | Fixed in |
|---|---|---|
github.com/containers/podman Go | All versions | None |
github.com/containers/podman Go | From 4.4.0 | 5.8.8 |
github.com/containers/podman Go | From 4.4.0 | 5.8.8 |
github.com/containers/podman/v2 Go | All versions | None |
github.com/containers/podman/v3 Go | All versions | None |
github.com/containers/podman/v4 Go | From 4.4.0 | None |
4 more packages
github.com/containers/podman/v5 Go | All versions | 5.8.8 |
go.podman.io/podman/v6 Go | From 6.0.0 | 6.1.3 |
go.podman.io/podman/v6 Go | From 6.0.0 | 6.1.3 |
go.podman.io/podman/v6 Go | From 6.0.0 | 6.1.3 |
Linux distribution packages (9)
podman AlmaLinux:10 | All versions | 7:5.8.2-10.el10_2.alma.1 |
podman-docker AlmaLinux:10 | All versions | 7:5.8.2-10.el10_2.alma.1 |
podman-remote AlmaLinux:10 | All versions | 7:5.8.2-10.el10_2.alma.1 |
podman-tests AlmaLinux:10 | All versions | 7:5.8.2-10.el10_2.alma.1 |
podman Red Hat:hummingbird:1 | All versions | 0:6.1.2-1.1.hum1 |
podman-docker Red Hat:hummingbird:1 | All versions | 0:6.1.2-1.1.hum1 |
podman-machine Red Hat:hummingbird:1 | All versions | 0:6.1.2-1.1.hum1 |
podman-remote Red Hat:hummingbird:1 | All versions | 0:6.1.2-1.1.hum1 |
podmansh Red Hat:hummingbird:1 | All versions | 0:6.1.2-1.1.hum1 |
How do I fix CVE-2026-94603?
Upgrade github.com/containers/podman to 5.8.8 or later.
Is CVE-2026-94603 being exploited?
There is no known exploitation of CVE-2026-94603 in the wild and no public exploit code.
Sources
Also known as ALSA-2026:88202, AZL-108315, AZL-108390, BELL-CVE-2026-94603, CLSA-2026-1792206152, DEBIAN-CVE-2026-94603 and 7 more.