# CVE-2026-94603: Podman: The `podman run` command can be instructed to disable almost all sandboxing by image annotation

> Attackers can bypass container sandboxing restrictions via image annotations, potentially escalating privileges within the host environment.

- **Severity:** Critical 10.0 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Oct 2026
- **Updated:** 13 Oct 2026
- **Also known as:** ALSA-2026:88202, AZL-108315, AZL-108390, BELL-CVE-2026-94603, CLSA-2026-1792206152, DEBIAN-CVE-2026-94603, ECHO-3a35-ea8e-3001, GHSA-2cvf-wqm6-wr9g, GO-2026-6770, MINI-9qrw-c8xm-xh7r, MINI-xpcr-23c6-63wm, RHSA-2026:74178, UBUNTU-CVE-2026-94603

## What is CVE-2026-94603?

CVE-2026-94603 is a critical vulnerability in podman-container-tools podman, published on 13 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Podman is a tool for managing OCI containers and pods. From 4.4.0 until 5.8.8 and 6.1.3, podman run treats an image carrying the io.podman.annotations.checkpoint.runtime.name annotation as a checkpoint and silently ignores user-supplied container creation restrictions such as --cap-drop=ALL, allowing image-controlled checkpoint state to select weaker sandbox settings and capabilities. Rootless containers are not affected because checkpoint and restore are unavailable in that mode. This issue is fixed in versions 5.8.8 and 6.1.3.

Weakness: CWE-693 (Protection Mechanism Failure)

## Which versions are affected by CVE-2026-94603?

10 open source packages ship an affected version, including github.com/containers/podman, github.com/containers/podman/v2 and github.com/containers/podman/v3.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/containers/podman` | Go | All versions | None |
| `github.com/containers/podman` | Go | From 4.4.0 | 5.8.8 |
| `github.com/containers/podman` | Go | From 4.4.0 | 5.8.8 |
| `github.com/containers/podman/v2` | Go | All versions | None |
| `github.com/containers/podman/v3` | Go | All versions | None |
| `github.com/containers/podman/v4` | Go | From 4.4.0 | None |
| `github.com/containers/podman/v5` | Go | All versions | 5.8.8 |
| `go.podman.io/podman/v6` | Go | From 6.0.0 | 6.1.3 |
| `go.podman.io/podman/v6` | Go | From 6.0.0 | 6.1.3 |
| `go.podman.io/podman/v6` | Go | From 6.0.0 | 6.1.3 |
| `podman` | AlmaLinux:10 | All versions | 7:5.8.2-10.el10_2.alma.1 |
| `podman-docker` | AlmaLinux:10 | All versions | 7:5.8.2-10.el10_2.alma.1 |
| `podman-remote` | AlmaLinux:10 | All versions | 7:5.8.2-10.el10_2.alma.1 |
| `podman-tests` | AlmaLinux:10 | All versions | 7:5.8.2-10.el10_2.alma.1 |
| `podman` | Red Hat:hummingbird:1 | All versions | 0:6.1.2-1.1.hum1 |
| `podman-docker` | Red Hat:hummingbird:1 | All versions | 0:6.1.2-1.1.hum1 |
| `podman-machine` | Red Hat:hummingbird:1 | All versions | 0:6.1.2-1.1.hum1 |
| `podman-remote` | Red Hat:hummingbird:1 | All versions | 0:6.1.2-1.1.hum1 |
| `podmansh` | Red Hat:hummingbird:1 | All versions | 0:6.1.2-1.1.hum1 |

## How do I fix CVE-2026-94603?

Upgrade github.com/containers/podman to 5.8.8 or later.

## Is CVE-2026-94603 being exploited?

There is no known exploitation of CVE-2026-94603 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-94603 and fix it if it is affected.

What it is: CVE-2026-94603 is a critical vulnerability in podman-container-tools podman, published on 13 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-94603 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/containers/podman (Go): affected all versions; no fix listed
- github.com/containers/podman (Go): affected from 4.4.0; fixed in 5.8.8
- github.com/containers/podman (Go): affected from 4.4.0; fixed in 5.8.8
- github.com/containers/podman/v2 (Go): affected all versions; no fix listed
- github.com/containers/podman/v3 (Go): affected all versions; no fix listed
- github.com/containers/podman/v4 (Go): affected from 4.4.0; no fix listed
- github.com/containers/podman/v5 (Go): affected all versions; fixed in 5.8.8
- go.podman.io/podman/v6 (Go): affected from 6.0.0; fixed in 6.1.3
- go.podman.io/podman/v6 (Go): affected from 6.0.0; fixed in 6.1.3
- go.podman.io/podman/v6 (Go): affected from 6.0.0; fixed in 6.1.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-94603/ (Markdown: https://insights.sbomify.com/CVE-2026-94603/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-94603
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-94603
- OSV: https://osv.dev/vulnerability/CVE-2026-94603

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-94603/
Summaries are generated and may contain mistakes; the official description above is the record.
