# CVE-2026-94606: authentik: MFA Bypass via State Confusion / Parameter Injection in AuthenticatorEmailStage

> Attackers with valid passwords can bypass MFA enrollment by injecting their own email address, gaining unauthorized access to user accounts and SSO applications.

- **Severity:** High 8.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Sep 2026
- **Updated:** 5 Oct 2026
- **Also known as:** BIT-authentik-2026-94606, GHSA-qgqp-xh8r-v73r

## What is CVE-2026-94606?

CVE-2026-94606 is a high-severity authentication bypass vulnerability in goauthentik authentik, published on 24 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

authentik is an open-source identity provider. Prior to 2026.2.7, 2026.5.7, and 2026.8.2, authentik email authenticator enrollment during an authentication or enrollment flow accepts a recipient address supplied in the setup request instead of using the address already established by the flow. An actor who knows a target user's password can substitute an attacker-controlled address, receive the one-time code, and finish enrolling the factor as the target. The target must not have enrolled the email factor already. Successful enrollment gives the actor a session as the target and access to single sign-on applications behind the account. Other authenticator types are not affected. This issue is fixed in versions 2026.2.7, 2026.5.7, and 2026.8.2.

Weakness: CWE-807 (Reliance on Untrusted Inputs in a Security Decision), CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2026-94606?

1 open source package ship an affected version, including authentik.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `authentik` | Bitnami | All versions | 2026.2.7, 2026.5.7, 2026.8.2 |

## How do I fix CVE-2026-94606?

Upgrade authentik to a fixed version for your release line: 2026.2.7, 2026.5.7 or 2026.8.2.

## Is CVE-2026-94606 being exploited?

There is no known exploitation of CVE-2026-94606 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-94606 and fix it if it is affected.

What it is: CVE-2026-94606 is a high-severity authentication bypass vulnerability in goauthentik authentik, published on 24 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-94606 in the wild and no public exploit code.

Affected packages and fixed versions:
- authentik (Bitnami): affected all versions; fixed in 2026.2.7, 2026.5.7, 2026.8.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-94606/ (Markdown: https://insights.sbomify.com/CVE-2026-94606/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-94606
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-94606
- OSV: https://osv.dev/vulnerability/CVE-2026-94606

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-94606/
Summaries are generated and may contain mistakes; the official description above is the record.
