CVE-2026-94609 authentik: Privilege Escalation to Superuser via Group Hierarchy
Attackers with delegated group management permissions can escalate to superuser status due to missing authorization checks in group hierarchy and role assignment logic.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-94609?
CVE-2026-94609 is a high-severity vulnerability in goauthentik authentik, published on 24 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
authentik is an open-source identity provider. Prior to 2026.2.7, 2026.5.7, and 2026.8.2, an account with delegated permission to manage a group, group membership, or a user can grant superuser status to an account or assign an existing role to a group without holding the permissions that gate those privileges. Group hierarchy checks do not consistently account for superuser status inherited from ancestor groups, and role assignment to a group lacks the required authorization check. Only deployments that delegate these management capabilities to accounts that are not full administrators are affected. This issue is fixed in versions 2026.2.7, 2026.5.7, and 2026.8.2.
Which versions are affected by CVE-2026-94609?
1 open source package ship an affected version, including authentik.
| Package | Affected | Fixed in |
|---|---|---|
authentik Bitnami | All versions | 2026.2.7, 2026.5.7, 2026.8.2 |
How do I fix CVE-2026-94609?
Upgrade authentik to a fixed version for your release line: 2026.2.7, 2026.5.7 or 2026.8.2.
Is CVE-2026-94609 being exploited?
There is no known exploitation of CVE-2026-94609 in the wild and no public exploit code.
Public exploit code: 1 proofs of concept on GitHub.
Sources
Also known as BIT-authentik-2026-94609, GHSA-h6c5-mpvq-j4jc.