{"answers":{"affected":"1 open source package ship an affected version, including authentik.","exploited":"There is no known exploitation of CVE-2026-94609 in the wild and no public exploit code.","fix":"Upgrade authentik to a fixed version for your release line: 2026.2.7, 2026.5.7 or 2026.8.2.","what":"CVE-2026-94609 is a high-severity vulnerability in goauthentik authentik, published on 24 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-94609 and fix it if it is affected.\n\nWhat it is: CVE-2026-94609 is a high-severity vulnerability in goauthentik authentik, published on 24 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-94609 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- authentik (Bitnami): affected all versions; fixed in 2026.2.7, 2026.5.7, 2026.8.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-94609/ (Markdown: https://insights.sbomify.com/CVE-2026-94609/index.md)","id":"CVE-2026-94609","markdown":"https://insights.sbomify.com/CVE-2026-94609/index.md","name":"CVE-2026-94609","record":{"aliases":["BIT-authentik-2026-94609","GHSA-h6c5-mpvq-j4jc"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["privilege_escalation"],"network_reachable":"yes","non_default_config":true,"product_category":"Identity provider","requires_auth":"low_privilege","summary":"Attackers with delegated group management permissions can escalate to superuser status due to missing authorization checks in group hierarchy and role assignment logic.","user_interaction":"not_required","vuln_class":"privilege_escalation"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-863","name":"Incorrect Authorization"},{"id":"CWE-269","name":"Improper Privilege Management"}],"description":"authentik is an open-source identity provider. Prior to 2026.2.7, 2026.5.7, and 2026.8.2, an account with delegated permission to manage a group, group membership, or a user can grant superuser status to an account or assign an existing role to a group without holding the permissions that gate those privileges. Group hierarchy checks do not consistently account for superuser status inherited from ancestor groups, and role assignment to a group lacks the required authorization check. Only deployments that delegate these management capabilities to accounts that are not full administrators are affected. This issue is fixed in versions 2026.2.7, 2026.5.7, and 2026.8.2.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":"2026-09-24","github_poc":1,"max_poc_stars":0,"metasploit":0,"nuclei":0,"refs":[{"date":"2026-09-24T17:32:31Z","kind":"github_poc","ref":"https://github.com/anthonyk2923/CVE-2026-94609","stars":0,"title":"CVE-2026-94609: Writeup and POC"}],"tier":"poc_unverified"},"has_fix":true,"headline":"authentik: Privilege Escalation to Superuser via Group Hierarchy","id":"CVE-2026-94609","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"privilege_escalation","year":"2026"},"n_packages":1,"n_references":15,"next":{"headline":"authentik: Stored credentials are readable with view permission alone","id":"CVE-2026-94611"},"packages":[{"ecosystem":"Bitnami","fixed":["2026.2.7","2026.5.7","2026.8.2"],"introduced":["0","2026.5.0","2026.8.0"],"last_affected":[],"package":"authentik","purl":"pkg:bitnami/authentik","source":"BIT-authentik-2026-94609"}],"prev":{"headline":"authentik: MFA Bypass via State Confusion / Parameter Injection in AuthenticatorEmailStage","id":"CVE-2026-94606"},"products":["authentik"],"published":"2026-09-24","related":[],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-09-28","vendors":["goauthentik"]},"summary":"Attackers with delegated group management permissions can escalate to superuser status due to missing authorization checks in group hierarchy and role assignment logic.","url":"https://insights.sbomify.com/CVE-2026-94609/"}