# CVE-2026-94609: authentik: Privilege Escalation to Superuser via Group Hierarchy

> Attackers with delegated group management permissions can escalate to superuser status due to missing authorization checks in group hierarchy and role assignment logic.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Sep 2026
- **Updated:** 28 Sep 2026
- **Also known as:** BIT-authentik-2026-94609, GHSA-h6c5-mpvq-j4jc

## What is CVE-2026-94609?

CVE-2026-94609 is a high-severity vulnerability in goauthentik authentik, published on 24 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

authentik is an open-source identity provider. Prior to 2026.2.7, 2026.5.7, and 2026.8.2, an account with delegated permission to manage a group, group membership, or a user can grant superuser status to an account or assign an existing role to a group without holding the permissions that gate those privileges. Group hierarchy checks do not consistently account for superuser status inherited from ancestor groups, and role assignment to a group lacks the required authorization check. Only deployments that delegate these management capabilities to accounts that are not full administrators are affected. This issue is fixed in versions 2026.2.7, 2026.5.7, and 2026.8.2.

Weakness: CWE-863 (Incorrect Authorization), CWE-269 (Improper Privilege Management)

## Which versions are affected by CVE-2026-94609?

1 open source package ship an affected version, including authentik.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `authentik` | Bitnami | All versions | 2026.2.7, 2026.5.7, 2026.8.2 |

## How do I fix CVE-2026-94609?

Upgrade authentik to a fixed version for your release line: 2026.2.7, 2026.5.7 or 2026.8.2.

## Is CVE-2026-94609 being exploited?

There is no known exploitation of CVE-2026-94609 in the wild and no public exploit code.

Public exploit code:

- CVE-2026-94609: Writeup and POC (github_poc): https://github.com/anthonyk2923/CVE-2026-94609

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-94609 and fix it if it is affected.

What it is: CVE-2026-94609 is a high-severity vulnerability in goauthentik authentik, published on 24 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-94609 in the wild and no public exploit code.

Affected packages and fixed versions:
- authentik (Bitnami): affected all versions; fixed in 2026.2.7, 2026.5.7, 2026.8.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-94609/ (Markdown: https://insights.sbomify.com/CVE-2026-94609/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-94609
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-94609
- OSV: https://osv.dev/vulnerability/CVE-2026-94609

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-94609/
Summaries are generated and may contain mistakes; the official description above is the record.
