CVE-2026-94611 authentik: Stored credentials are readable with view permission alone
Attackers with view permissions can read stored credentials in various authentik configurations, exposing sensitive secrets.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-94611?
CVE-2026-94611 is a high-severity vulnerability in goauthentik authentik, published on 24 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
authentik is an open-source identity provider. Prior to 2026.2.7, 2026.5.7, and 2026.8.2, authentik API serializers return stored credentials when an account has view permission on an affected configuration, even when that account is not authorized to change the configuration or read its secrets. Affected configurations include one-time code delivery by mail or SMS, outbound provisioning targets, device trust integrations, identity sources, the Kubernetes outpost integration, applications using a client or shared secret, and applications using a proxy provider. Deployments are affected when view permission is granted to accounts that are not intended to read these credentials; deployments where every viewer is permitted to read them are not affected. This issue is fixed in versions 2026.2.7, 2026.5.7, and 2026.8.2.
Which versions are affected by CVE-2026-94611?
1 open source package ship an affected version, including authentik.
| Package | Affected | Fixed in |
|---|---|---|
authentik Bitnami | All versions | 2026.2.7, 2026.5.7, 2026.8.2 |
How do I fix CVE-2026-94611?
Upgrade authentik to a fixed version for your release line: 2026.2.7, 2026.5.7 or 2026.8.2.
Is CVE-2026-94611 being exploited?
There is no known exploitation of CVE-2026-94611 in the wild and no public exploit code.
Sources
Also known as BIT-authentik-2026-94611, GHSA-m9h4-7j9c-55x9.