{"answers":{"affected":"1 open source package ship an affected version, including authentik.","exploited":"There is no known exploitation of CVE-2026-94611 in the wild and no public exploit code.","fix":"Upgrade authentik to a fixed version for your release line: 2026.2.7, 2026.5.7 or 2026.8.2.","what":"CVE-2026-94611 is a high-severity vulnerability in goauthentik authentik, published on 24 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-94611 and fix it if it is affected.\n\nWhat it is: CVE-2026-94611 is a high-severity vulnerability in goauthentik authentik, published on 24 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-94611 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- authentik (Bitnami): affected all versions; fixed in 2026.2.7, 2026.5.7, 2026.8.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-94611/ (Markdown: https://insights.sbomify.com/CVE-2026-94611/index.md)","id":"CVE-2026-94611","markdown":"https://insights.sbomify.com/CVE-2026-94611/index.md","name":"CVE-2026-94611","record":{"aliases":["BIT-authentik-2026-94611","GHSA-m9h4-7j9c-55x9"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":true,"product_category":"Identity provider","requires_auth":"low_privilege","summary":"Attackers with view permissions can read stored credentials in various authentik configurations, exposing sensitive secrets.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.1,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-522","name":"Insufficiently Protected Credentials"},{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"}],"description":"authentik is an open-source identity provider. Prior to 2026.2.7, 2026.5.7, and 2026.8.2, authentik API serializers return stored credentials when an account has view permission on an affected configuration, even when that account is not authorized to change the configuration or read its secrets. Affected configurations include one-time code delivery by mail or SMS, outbound provisioning targets, device trust integrations, identity sources, the Kubernetes outpost integration, applications using a client or shared secret, and applications using a proxy provider. Deployments are affected when view permission is granted to accounts that are not intended to read these credentials; deployments where every viewer is permitted to read them are not affected. This issue is fixed in versions 2026.2.7, 2026.5.7, and 2026.8.2.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"authentik: Stored credentials are readable with view permission alone","id":"CVE-2026-94611","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"information_disclosure","year":"2026"},"n_packages":1,"n_references":15,"next":{"headline":"authentik: Authentication bypass via assertion confusion in SAML sources","id":"CVE-2026-94612"},"packages":[{"ecosystem":"Bitnami","fixed":["2026.2.7","2026.5.7","2026.8.2"],"introduced":["0","2026.5.0","2026.8.0"],"last_affected":[],"package":"authentik","purl":"pkg:bitnami/authentik","source":"BIT-authentik-2026-94611"}],"prev":{"headline":"authentik: Privilege Escalation to Superuser via Group Hierarchy","id":"CVE-2026-94609"},"products":["authentik"],"published":"2026-09-24","related":[],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-09-24","vendors":["goauthentik"]},"summary":"Attackers with view permissions can read stored credentials in various authentik configurations, exposing sensitive secrets.","url":"https://insights.sbomify.com/CVE-2026-94611/"}